incubator-ambari-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Guo Leitao <leitao....@gmail.com>
Subject Re: fail to start Ambari service
Date Mon, 10 Sep 2012 09:20:41 GMT
Hi Yusaku,

I passed 3rd step (Assign Master Services to Hosts) according to your
advice, but stop at step 7 in "Deployment Progress". The error message is
"Cluaster install failed". Would you kindly help to check what's wrong with
my configuration? Please find attatched hmc.log, /var/log/httpd/error_log
and OpentionLogs output in the webpage.

Thanks!

Leitao

2012/9/10 Yusaku Sako <yusaku@hortonworks.com>

> Hi Guo,
>
> When you added hosts in Step 2, did you use FQDN of the hosts?  The FQDNs
> should match what's given by the hosts when you run "hostname -f".
> I ask because of the previous issue that you encountered regarding
> certificate generation, and this can lead to other problems.
> If you did not use FQDN, then please try using the FQDN for the cluster
> hosts.  Also, please try accessing Ambari via the FQDN and not the IP
> address (I say this because I see "referer" as an IP address, not FQDN).
>
> Regarding the error_log output, "Undefined index:  KERBEROS_SERVER in
> /usr/share/hmc/php/frontend/selectServices.php on line 188" should not be
> happening so there's definitely something wrong.
> If you could also post your /var/log/hmc/hmc.log file, that would help us
> debug the issue for you.
>
> Thanks,
> Yusaku
>
>
>
> On Sun, Sep 9, 2012 at 7:10 PM, Guo Leitao <leitao.guo@gmail.com> wrote:
>
>> Hi Yusaku,
>>
>> I tried Firefox 15.0.1 and Chrome 21.0.1180.89 m, but all have failed.
>>
>> Here are the logs in "/var/log/httpd/error_log"
>>
>> [Mon Sep 10 10:07:49 2012] [error] [client 10.6.1.165] PHP Warning:
>> rmdir(/var/run/hmc/clusters/myTestCluster/) [<a
>> href='function.rmdir'>function.rmdir</a>]: No such file or directory in
>> /usr/share/hmc/php/frontend/localDirs.php on line 64, referer:
>> http://192.168.34.8/hmc/html/initializeCluster.php
>> [Mon Sep 10 10:07:49 2012] [error] [client 10.6.1.165] ClusterName:
>> myTestCluster, referer:
>> http://192.168.34.8/hmc/html/initializeCluster.php
>> [Mon Sep 10 10:08:33 2012] [error] [client 10.6.1.165] PHP Notice:
>> Undefined index:  KERBEROS_SERVER in
>> /usr/share/hmc/php/frontend/selectServices.php on line 188, referer:
>> http://192.168.34.8/hmc/html/initializeCluster.php
>> [Mon Sep 10 10:08:33 2012] [error] [client 10.6.1.165] PHP Notice:
>> Undefined index:  ZOOKEEPER_SERVER in
>> /usr/share/hmc/php/frontend/selectServices.php on line 188, referer:
>> http://192.168.34.8/hmc/html/initializeCluster.php
>> [Mon Sep 10 10:08:33 2012] [error] [client 10.6.1.165] PHP Notice:
>> Undefined index:  HBASE_MASTER in
>> /usr/share/hmc/php/frontend/selectServices.php on line 188, referer:
>> http://192.168.34.8/hmc/html/initializeCluster.php
>> [Mon Sep 10 10:08:33 2012] [error] [client 10.6.1.165] PHP Notice:
>> Undefined index:  OOZIE_SERVER in
>> /usr/share/hmc/php/frontend/selectServices.php on line 188, referer:
>> http://192.168.34.8/hmc/html/initializeCluster.php
>> [Mon Sep 10 10:08:33 2012] [error] [client 10.6.1.165] PHP Notice:
>> Undefined index:  HIVE_SERVER in
>> /usr/share/hmc/php/frontend/selectServices.php on line 188, referer:
>> http://192.168.34.8/hmc/html/initializeCluster.php
>> [Mon Sep 10 10:08:33 2012] [error] [client 10.6.1.165] PHP Notice:
>> Undefined index:  TEMPLETON_SERVER in
>> /usr/share/hmc/php/frontend/selectServices.php on line 188, referer:
>> http://192.168.34.8/hmc/html/initializeCluster.php
>>
>> Thanks,
>>
>> Leitao
>>
>>
>> 2012/9/10 Yusaku Sako <yusaku@hortonworks.com>
>>
>>> Hi Guo,
>>>
>>> What browser are you using?
>>> FYI, in general the developers have been testing Ambari using Firefox
>>> 14/15 (but recent versions of Chrome should work - IE most likely will not
>>> work).
>>>
>>> Thanks,
>>> Yusaku
>>>
>>>
>>> On Sun, Sep 9, 2012 at 10:43 AM, Guo Leitao <leitao.guo@gmail.com>wrote:
>>>
>>>> Hi Hitesh,
>>>>
>>>> Thanks for your kindly help. It works! But I find a new question about
>>>> ambari.
>>>> When start ambari service successfully, I following the instruction of
>>>> website "http://AMBARIMASTER/hmc/html/" to deploy Hadoop.
>>>> In the 3rd step, that is "Assign Master Services to Hosts", there is no
>>>> any response of the button "Next". Seems there is a javascript error.
>>>>
>>>> - Leitao
>>>>
>>>>
>>>> 2012/9/6 Hitesh Shah <hitesh@hortonworks.com>
>>>>
>>>>> The error is likely due to a missing ssl cert.
>>>>>
>>>>> Try this in the following order:
>>>>>
>>>>> $service ambari stop
>>>>> $sudo puppet master --no-daemonize --debug
>>>>> [ this will run in the foreground so once it comes up , go ahead and
>>>>> kill it once the logs stop scrolling ]
>>>>> $service ambari start
>>>>>
>>>>> The intermediate step is to create the ssl certificate if it did not
>>>>> get created or was deleted by mistake.
>>>>>
>>>>> -- Hitesh
>>>>>
>>>>> On Sep 6, 2012, at 1:47 AM, Guo Leitao wrote:
>>>>>
>>>>> > I'm new to Ambari, and this is my first to config Ambari.
>>>>> >
>>>>> > After installed ambari-agent, ambari andhdp_mon_dashboard according
>>>>> to http://incubator.apache.org/ambari/install.html, I can not start
>>>>> ambari service.  Here is error output. Any more configuration to puppet
>>>>> should I do? Thanks!
>>>>> >
>>>>> > # service ambari start
>>>>> > Starting Ambari Installer
>>>>> > Starting httpd: Syntax error on line 35 of /etc/httpd/conf.d/
>>>>> > puppetmaster.conf:
>>>>> > SSLCertificateFile: file
>>>>> '/var/lib/puppet/ssl/certs/compute-34-09.local.pem' does not exist or
is
>>>>> empty
>>>>> >                                                            [FAILED]
>>>>> > Failed to start Ambari
>>>>>
>>>>>
>>>>
>>>
>>
>

Mime
View raw message