incubator-ambari-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Guo Leitao <leitao....@gmail.com>
Subject Re: fail to start Ambari service
Date Sun, 09 Sep 2012 17:43:47 GMT
Hi Hitesh,

Thanks for your kindly help. It works! But I find a new question about
ambari.
When start ambari service successfully, I following the instruction of
website "http://AMBARIMASTER/hmc/html/" to deploy Hadoop.
In the 3rd step, that is "Assign Master Services to Hosts", there is no any
response of the button "Next". Seems there is a javascript error.

- Leitao

2012/9/6 Hitesh Shah <hitesh@hortonworks.com>

> The error is likely due to a missing ssl cert.
>
> Try this in the following order:
>
> $service ambari stop
> $sudo puppet master --no-daemonize --debug
> [ this will run in the foreground so once it comes up , go ahead and kill
> it once the logs stop scrolling ]
> $service ambari start
>
> The intermediate step is to create the ssl certificate if it did not get
> created or was deleted by mistake.
>
> -- Hitesh
>
> On Sep 6, 2012, at 1:47 AM, Guo Leitao wrote:
>
> > I'm new to Ambari, and this is my first to config Ambari.
> >
> > After installed ambari-agent, ambari andhdp_mon_dashboard according to
> http://incubator.apache.org/ambari/install.html, I can not start ambari
> service.  Here is error output. Any more configuration to puppet should I
> do? Thanks!
> >
> > # service ambari start
> > Starting Ambari Installer
> > Starting httpd: Syntax error on line 35 of /etc/httpd/conf.d/
> > puppetmaster.conf:
> > SSLCertificateFile: file
> '/var/lib/puppet/ssl/certs/compute-34-09.local.pem' does not exist or is
> empty
> >                                                            [FAILED]
> > Failed to start Ambari
>
>

Mime
View raw message