incubator-ambari-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From shidongjie <shidongj...@sina.com>
Subject Re: Re: ambari install error
Date Thu, 02 Aug 2012 10:46:47 GMT
thank you for your reply
     I have installed ambari success




shidongjie

From: Hitesh Shah
Date: 2012-08-02 12:05
To: ambari-user
Subject: Re: ambari install error
Hi

I see the issue - this is a result of the documentation lagging behind a bit. The error is
showing up you are using a slighter older repo that does not have the rpm in question whereas
the modified code requires it. 

Could you update your repo file by either using one of the following based on your os type
and re-try the installation:

rpm -Uvh http://public-repo-1.hortonworks.com/HDP-1.0.1.14/repos/centos5/hdp-release-1.0.1.14-1.el5.noarch.rpm
( for rhel5/centos5 )

OR

rpm -Uvh http://public-repo-1.hortonworks.com/HDP-1.0.1.14/repos/centos6/hdp-release-1.0.1.14-1.el6.noarch.rpm
(for rhel6/centos6 )

-- Hitesh

On Aug 1, 2012, at 6:18 PM, shidongjie wrote:

> Thank you for your reply
>  
>       I find in path  /var/lib//puppet/reports/9-3-2/ ,there is two report files,
>       hadooptestnode2.qyops.com  hadooptestnode3.qyops.com
>  
>       
>  #  grep "err)" hadooptestnode2.qyops.com 
>       message: "Wed Aug 01 17:59:07 +0800 2012 /Stage[main]/Hdp-hadoop/Hdp-hadoop::Package[hadoop]/Hdp::Package[hadoop
64]/Hdp::Package::Yum[hadoop 64]/Package[hadoop-lzo-native]/ensure (err): change from absent
to present failed: Could not find package hadoop-lzo-native"
> # grep "err)" hadooptestnode3.qyops.com 
>       message: "Wed Aug 01 17:58:27 +0800 2012 /Stage[main]/Hdp-hadoop/Hdp-hadoop::Package[hadoop]/Hdp::Package[hadoop
64]/Hdp::Package::Yum[hadoop 64]/Package[hadoop-lzo-native]/ensure (err): change from absent
to present failed: Could not find package hadoop-lzo-native"
>        
>   #yum list|grep hadoop-lzo-native      no result  
> shidongjie
>  
> From: Hitesh Shah
> Date: 2012-08-01 22:31
> To: ambari-user
> Subject: Re: ambari install error
> Hi again, 
>  
> On the puppet master i.e. the ambari master, could you go into /var/lib/puppet/reports/9-3-2/.
There should be 2 report files in there for each host in question. Could you grep through
them to find "err)" - the first match in each file will tell you what command failed causing
the install failure. 
>  
> -- Hitesh 
>  
> On Aug 1, 2012, at 3:05 AM, shidongjie wrote:
>  
> > Hi,everyone   
> >      I encountered an error while installing ambari,error is
> >      
> >  "3": {
> >         "nodeReport": {
> >             "PUPPET_KICK_FAILED": [],
> >             "PUPPET_OPERATION_FAILED": [
> >                 "hadooptestnode2.qyops.com",
> >                 "hadooptestnode3.qyops.com"
> >             ],
> >             "PUPPET_OPERATION_TIMEDOUT": [],
> >             "PUPPET_OPERATION_SUCCEEDED": []
> >         },
> >         "nodeLogs": {
> >             "hadooptestnode2.qyops.com": {
> >                 "reportfile": "/var/lib/puppet/reports/9-3-2/hadooptestnode2.qyops.com",
> >                 "overall": "FAILED",
> >                 "finishtime": "2012-08-01 17:57:56.253304 +08:00",
> >                 "message": [
> >                     "Loaded state in 0.00 seconds",
> >                     "Loading facts in kadm_keytab",
> >                     "Loading facts in kadm_keytab",
> >                     "Not using expired catalog for hadooptestnode2.qyops.com from
cache; expired at Wed Aug 01 08:57:51 +0800 2012",
> >                     "Using cached catalog",
> >                     "\"catalog supports formats: b64_zlib_yaml dot marshal pson
raw yaml; using pson\"",
> >                     "Caching catalog for hadooptestnode2.qyops.com",
> >                     "Creating default schedules",
> >                     "Loaded state in 0.00 seconds",
> >                     "Applying configuration version '9-3-2'",
> >                     "\"requires Exec[untar_modules]\"",
> >                     "\"requires Exec[puppet_apply]\"",
> >                     "Skipping device resources because running on a host",
> >                     "Skipping device resources because running on a host",
> >                     "Skipping device resources because running on a host",
> >                     "Skipping device resources because running on a host",
> >                     "Skipping device resources because running on a host",
> >                     "Skipping device resources because running on a host",
> >                     "\"file_metadata supports formats: b64_zlib_yaml marshal pson
raw yaml; using pson\"",
> >                     "Finishing transaction 23557468746320",
> >                     "\"FileBucket adding {md5}687ce724cdb45cc92c9a03cfcea4f8a8\"",
> >                     "Filebucketed /etc/puppet/agent/modules.tgz to puppet with sum
687ce724cdb45cc92c9a03cfcea4f8a8",
> >                     "&id005 \"content changed '{md5}687ce724cdb45cc92c9a03cfcea4f8a8'
to '{md5}d978d81059216cfaa660e9e180587b26'\"",
> >                     "\"The container Class[Manifestloader] will propagate my refresh
event\"",
> >                     "Executing 'rm -rf /etc/puppet/agent/modules ; tar zxf /etc/puppet/agent/modules.tgz
-C /etc/puppet/agent/ --strip-components 3'",
> >                     "Executing 'rm -rf /etc/puppet/agent/modules ; tar zxf /etc/puppet/agent/modules.tgz
-C /etc/puppet/agent/ --strip-components 3'",
> >                     "&id002 executed successfully",
> >                     "\"The container Class[Manifestloader] will propagate my refresh
event\"",
> >                     "Executing 'sh /etc/puppet/agent/modules/puppetApply.sh'",
> >                     "Executing 'sh /etc/puppet/agent/modules/puppetApply.sh'",
> >                     "\"Wed Aug 01 17:57:58 +0800 2012 Puppet (info): Loading facts
in kadm_keytab\"",
> >                     "\"Could not retrieve selinux: Invalid argument - /proc/self/attr/current\"",
> >                     "\"Could not retrieve selinux: Invalid argument - /proc/self/attr/current\"",
> >                     "\"Could not retrieve selinux: Invalid argument - /proc/self/attr/current\"",
> >                     "\"Could not retrieve selinux: Invalid argument - /proc/self/attr/current\"",
> >                     "\"Could not retrieve selinux: Invalid argument - /proc/self/attr/current\"",
> >                     "\"Could not retrieve selinux: Invalid argument - /proc/self/attr/current\"",
> >                     "\"Could not retrieve selinux: Invalid argument - /proc/self/attr/current\"",
> >                     "\"Could not retrieve selinux: Invalid argument - /proc/self/attr/current\"",
> >  
> > Cluster operating system is centos 5.8 ,
> > May I ask how to solve it
> > shidongjie
>  
>  
Mime
View raw message