incubator-ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dmytro Shkvyra (JIRA)" <j...@apache.org>
Subject [jira] [Created] (AMBARI-3679) Better error message needed when incompatible ambari-agents installed
Date Mon, 04 Nov 2013 16:21:18 GMT
Dmytro Shkvyra created AMBARI-3679:
--------------------------------------

             Summary: Better error message needed when incompatible ambari-agents installed
                 Key: AMBARI-3679
                 URL: https://issues.apache.org/jira/browse/AMBARI-3679
             Project: Ambari
          Issue Type: Bug
          Components: agent
    Affects Versions: 1.4.1
            Reporter: Dmytro Shkvyra
             Fix For: 1.4.2


On a few days old cluster I attempted to add a host. The add host failed due to ambari-server
trying to install ambari-agent-1.4.1.17 and the repo having ambari-agent-1.4.1.23-1.
The message in /var/run/ambari-server/bootstrap/11/hostname.log was:
STDERR
scp /usr/lib/python2.6/site-packages/ambari_server/setupAgent.py done for host srimanth1-5.c.pramod-thangali.internal,
exitcode=0
Copying files finished
Running setup agent...
STDOUT
Error: Nothing to do
{'exitstatus': 1, 'log': ('Loaded plugins: downloadonly, fastestmirror, security\nDetermining
fastest mirrors\n * base: www.gtlib.gatech.edu\n * extras: centos.mirror.netriplex.com\n *
updates: mirror.cogentco.com\nSetting up Install Process\nNo package ambari-agent-1.4.1.17
available.\n', None)}




--
This message was sent by Atlassian JIRA
(v6.1#6144)

Mime
View raw message