incubator-ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dmitry Lysnichenko (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (AMBARI-2930) Whether security is enabled or not should be keyed off of "hadoop.security.authentication" in "core-site.xml", not "security_enabled" global param
Date Wed, 21 Aug 2013 13:11:52 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-2930?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Dmitry Lysnichenko resolved AMBARI-2930.
----------------------------------------

    Resolution: Fixed

committed to trunk 
                
> Whether security is enabled or not should be keyed off of "hadoop.security.authentication"
in "core-site.xml", not "security_enabled" global param
> --------------------------------------------------------------------------------------------------------------------------------------------------
>
>                 Key: AMBARI-2930
>                 URL: https://issues.apache.org/jira/browse/AMBARI-2930
>             Project: Ambari
>          Issue Type: Improvement
>          Components: agent
>    Affects Versions: 1.2.5
>            Reporter: Vitaly Brodetskyi
>            Assignee: Vitaly Brodetskyi
>            Priority: Critical
>             Fix For: 1.4.1
>
>         Attachments: AMBARI-2930.patch
>
>   Original Estimate: 16h
>  Remaining Estimate: 16h
>
> If hadoop.security.authentication in core-site.xml is set to "kerberos", security is
assumed to be enabled. If it is set to "simple" or any other value, security is assumed to
be disabled. "security_enabled" global should no longer be used and should be removed.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message