incubator-ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sumit Mohanty (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (AMBARI-2141) When hbase user is changed hbase does not start properly after upgrade
Date Thu, 16 May 2013 17:17:17 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-2141?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Sumit Mohanty resolved AMBARI-2141.
-----------------------------------

    Resolution: Fixed
    
> When hbase user is changed hbase does not start properly after upgrade
> ----------------------------------------------------------------------
>
>                 Key: AMBARI-2141
>                 URL: https://issues.apache.org/jira/browse/AMBARI-2141
>             Project: Ambari
>          Issue Type: Bug
>    Affects Versions: 1.2.4
>            Reporter: Sumit Mohanty
>            Assignee: Sumit Mohanty
>             Fix For: 1.2.4
>
>         Attachments: AMBARI-2141.patch
>
>
> Repro steps:
> * Install HDP 1.2.1 using current Ambari with users modified for all services and also
the hadoop group
> * Upgrade to 1.3.0
> When you start HBASE you will notice that FE indicates the service (hbase_master to be
exact) not started. Looking the host, hbase_master is running but the pid file is not created.
Therefore, the agent cannot report the component as started.
> The issue is that upgrade reverts the directory ownership and that does not get changed
before the start of the first component.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message