incubator-ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Yusaku Sako (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-2071) Cluster install wizard does not work with client-only service
Date Mon, 06 May 2013 22:50:20 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-2071?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13650200#comment-13650200
] 

Yusaku Sako commented on AMBARI-2071:
-------------------------------------

Looks like Chad's patch won't work if the server response is HTTP Code 200 with empty body.
I've simulated this flow by turning App.testMode = true in app/initialize.js and modifying
app/assets/data/wizard/deploy/5_hosts/poll_6.json so that the content is blank when the UI
issues the start API call.

In step9_controller::launchStartServices's ajax success callback throws a JS error on since
there's no "Requests" element in the context body while evaluating jsonData.Requests.id;
                
> Cluster install wizard does not work with client-only service
> -------------------------------------------------------------
>
>                 Key: AMBARI-2071
>                 URL: https://issues.apache.org/jira/browse/AMBARI-2071
>             Project: Ambari
>          Issue Type: Bug
>          Components: controller
>    Affects Versions: 1.2.0
>         Environment: Fedora 16, branch-1.2
>            Reporter: Trevor McKay
>         Attachments: clientonly.patch, notasksequalsdone.patch
>
>
> If the cluster install wizard is used to install a single client only service, the wizard
will hang after trying to move the service from INSTALLED -> STARTED.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message