incubator-ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ximo Guanter (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-1720) mvn build fails due to removing the ambari-web/public directory
Date Fri, 05 Apr 2013 07:36:15 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-1720?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13623438#comment-13623438
] 

Ximo Guanter commented on AMBARI-1720:
--------------------------------------

I have been able to repro this by accidentally installing Node v0.11 instead of v0.10.2 It
seems this causes the "brunch build" command to fail (which doesn't fail the build due to
ambari-web's POM settings) which in turn causes the public directory not to be created.
                
> mvn build fails due to removing the ambari-web/public directory
> ---------------------------------------------------------------
>
>                 Key: AMBARI-1720
>                 URL: https://issues.apache.org/jira/browse/AMBARI-1720
>             Project: Ambari
>          Issue Type: Bug
>          Components: build
>    Affects Versions: 1.2.0
>         Environment: fedora 18, java 1.6, python 2.7, mvn 3.0.4
>            Reporter: Jeff Vance
>            Assignee: Yusaku Sako
>            Priority: Minor
>
> mvn -X -B -e clean install package rpm:rpm -DskipTests -Dpython.ver="python >= 2.6"
  fails with missing ambari-web/public dir. I can't dup this now in my current env but I'll
try some more...

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message