incubator-ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yusaku Sako <yus...@hortonworks.com>
Subject Re: Issue in ambari-server setup
Date Tue, 02 Apr 2013 20:32:57 GMT
Hi,

We currently develop and test using Postgres 8.4 for RHEL 6.
If you want to use Postgres 9.2, then you may have to create a symlink
/etc/init.d/postgresql that points to /etc/init.d/postgresql-9.2.
But due to differences between Postgres 9.2 and 8.4 DDL, Ambari DB set up
may not work properly and you might run into other issues.
You are more than welcome to tackle these problems and provide patches to
make Ambari work with Postgres 9.2.
If you just want to get Ambari up and running, please install Postgres 8.4.

Yusaku

On Tue, Apr 2, 2013 at 4:37 AM, Sandeep Baldawa <sandeepbaldawa@gmail.com>wrote:

> Following instructions here
> https://cwiki.apache.org/AMBARI/ambari-development.html
>
> - Was able to do a maven build successfully.
>
> - yum install
>
> ./ambari-server/target/rpm/ambari-server/RPMS/noarch/ambari-server-1.3.0-*.noarch.rpm
> also went through fine
>
> - But when I run "ambari-server setup", I get the following:-
>
> Using python  /usr/bin/python2.6
> Run postgresql initdb
> postgresql: unrecognized service
> Run postgresql start
> postgresql: unrecognized service
> Setup ambari-server
> Checking SELinux...
> SELinux status is 'enabled'
> SELinux mode is 'permissive'
> WARNING: SELinux is set to 'permissive' mode and temporarily disabled. You
> should disable SELinux permanently.
> OK to continue [y/n] (y)? y
> Checking iptables...
> iptables is disabled now
> Checking PostgreSQL...
> About to start PostgreSQL
> ERROR: Unable to start PostgreSQL server. Exiting
>
> - I checked service postgresql-9.2 start and it returns ok.
>
> This is for Rhel6 64 bit
>
> Any clue as to what might be going wrong?
>
> Thanks!
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message