incubator-ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sumit Mohanty (JIRA)" <j...@apache.org>
Subject [jira] [Created] (AMBARI-1424) Upgrade Ambari for 1.3.0
Date Wed, 13 Feb 2013 00:43:13 GMT
Sumit Mohanty created AMBARI-1424:
-------------------------------------

             Summary: Upgrade Ambari for 1.3.0
                 Key: AMBARI-1424
                 URL: https://issues.apache.org/jira/browse/AMBARI-1424
             Project: Ambari
          Issue Type: Bug
    Affects Versions: 1.3.0
            Reporter: Sumit Mohanty
            Assignee: Sumit Mohanty
             Fix For: 1.3.0


* Modify upgrade to not overwrite configuration files (e.g. ambari-agent.ini). Upgrade or
a pre-install script will save the configurations. A post-install script will restore the
configuration file.
* Refactor RPM packages such that ambari can be managed as ambari\* removing the need to separately
install/upgrade server agents etc.
* Ambari upgrade ddl script
** Create a table to store Ambari metadata such as version information
** Check if its an upgrade from 1.2.0 or 1.2.1 and then apply appropriate upgrade script(s)
* Modify Ambari Server to check version in the store and fail start if its not greater than
desired
* Maintain a compatibility matrix for Agent versions and Server versions. If the agent version
is not compatible with Server’s then stop the agent and report failure. (For 1.3.0, all
Agents must be upgraded to the same version as the Server)

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message