incubator-ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paulo Ricardo Paz Vital <pvi...@linux.vnet.ibm.com>
Subject Re: Ambari Web Build Error
Date Wed, 20 Feb 2013 17:22:34 GMT
Hello Yusaku.

On 02/20/2013 02:11 AM, Yusaku Sako wrote:
> Hi Paulo,
>
> Thanks for chiming in.
> The warning message after running "npm install" is normal and is not
> Windows-specific.
> When I said Windows specific, I was referring to the Maven build errors
> that Tanzir was running into.
>
> For troubleshooting your issue...
> When you run "brunch watch --server" from ambari-web directory, does it
> show something like the following in the console?
>
> # brunch watch --server
> 19 Feb 21:06:44 - info: application started on http://localhost:3333/
> 19 Feb 21:06:45 - info: compiled in 963ms
>

Yes, I get the same messages here. Sometimes with only one "info: 
compiled" message, as you reported, other with two or three more messages.

> Do you get the login form when you hit http://localhost:3333 from your
> browser?
>

No, I can't see the login form, as showed in image [1]. The same happens 
when I build Ambari using Maven and install the RPMs.

> FYI, "brunch watch --server" is for testing Ambari Web (the web frontend)
> in isolation from Ambari Server.
> I just wanted to isolate where the problem is.
>

Yeah, after read the code and some design documents, I could check that 
the ambari-server is working well, but the web frontend looks doesn't, 
isolating the problem only on ambari-web.

Looks like that Brunch is working, once I could create a new example 
project in a different port and run the app, as show in [2].

> What OS/browser are you using?

I checked out the Ambari-1.2.0 release from SVN in a x86_64 RHEL 6.3 VM. 
All the development requirements described in wiki are are OK.

I tried to execute brunch with the DEBUG variable set, but the messages 
don't show any error or different message than expected.

Any suggestion about it?

Regards, Paulo.

[1] 
http://www.vital.eng.br/images/ambari/Screenshot-Ambari-Web_login_error.png
[2] http://www.vital.eng.br/images/ambari/Screenshot-Brunch_example.png

>
> Yusaku
>
>
> On Tue, Feb 19, 2013 at 5:17 AM, Paulo Ricardo Paz Vital<
> pvital@linux.vnet.ibm.com>  wrote:
>
>> Hello Yusaku,
>>
>> Not sure if this message is Windows specific only. I got the same message
>> when running on a RHEL6.3:
>>
>> [root@rhel63 ambari-web]# npm install
>>
>> npm WARN package.json Ambari@1.0.0 No README.md file found!
>> [root@rhel63 ambari-web]#
>>
>> In addition, when I execute "brunch watch --server" in ambari-web
>> directory, or try to install the RPMs generated after execute the full
>> Maven command in [1], I can't see the login form on the server machine - I
>> got a blank screen only with the footnote presenting the Apache License and
>> the Ambari Notice links.
>>
>> This happens when using IBM Java 6 SR 11 or Oracle Java 6 update 35, with
>> NodeJS 0.8.20 (compiled) and brunch 1.4.4 and/or 1.5.3.
>>
>> [1] https://cwiki.apache.org/**confluence/display/AMBARI/**
>> Ambari+Development<https://cwiki.apache.org/confluence/display/AMBARI/Ambari+Development>
>>
>> Best regards, Paulo.
>>
>>
>> On 02/19/2013 04:40 AM, Yusaku Sako wrote:
>>
>>> Looks like you are using Windows.
>>> This may be a Windows specific issue.
>>> Can you try editing ambari-web/pom.xml and try putting the full path to
>>> the
>>> npm executable with the correct extension in the line:
>>>
>>> <exec dir="${basedir}" executable="npm" failonerror="false">
>>>
>>> Ambari has been tested to run on RHEL 5/6 and SLES 11.
>>> Not sure what it would take to make it work on Windows.
>>>
>>> Yusaku
>>>
>>> On Mon, Feb 18, 2013 at 11:47 AM, Tanzir Musabbir<
>>> tanzir@customercaresolutions.**com<tanzir@customercaresolutions.com>>
>>>   wrote:
>>>
>>>   Thanks a lot Yusaku&   Mahadev for your prompt reply. I did install NodeJS
>>>>
>>>> &   Brunch (following the instruction) and tested with by typing both
>>>> "npm"
>>>> and "brunch" in command prompt (to check whether they are in the path)
>>>> and
>>>> both worked fine.
>>>>
>>>> This is what I got when I ran the mentioned command:
>>>>
>>>> ------------------------------****----------------------------**--**
>>>> --------------
>>>> D:\workspace-ambari\trunk\****ambari-web>npm install
>>>>
>>>> npm WARN package.json Ambari@1.0.0 No README.md file found!
>>>> ------------------------------****----------------------------**--**
>>>>
>>>> --------------
>>>>
>>>> But got that error when I ran the maven build. Any idea what I'm doing
>>>> wrong here?
>>>>
>>>>
>>>> Thanks in advance. Highly appreciate your time.
>>>>
>>>>
>>>>
>>>> - Tanzir
>>>>
>>>>
>>>>
>>>>
>>>>
>>>> On 2/18/2013 12:58 PM, Yusaku Sako wrote:
>>>>
>>>>   Hi Tanzir,
>>>>>
>>>>> It looks like the Maven output is saying it cannot find the "npm"
>>>>> command.
>>>>> The "npm" command needs to be in PATH such that you can run it from the
>>>>> "ambari-web" directory without specifying the full path.
>>>>>
>>>>> To verify:
>>>>> # cd trunk/ambari-web
>>>>> # npm install
>>>>> This should download node packages and store them in
>>>>> "ambari-web/node_modules".
>>>>>
>>>>> Hope this helps.
>>>>>
>>>>> Yusaku
>>>>>
>>>>> On Mon, Feb 18, 2013 at 9:09 AM, Tanzir Musabbir<
>>>>> tanzir@customercaresolutions.****com<tanzir@**customercaresolutions.com<tanzir@customercaresolutions.com>
>>>>>>>
>>>>> wrote:
>>>>>
>>>>>    Hello Everyone,
>>>>>
>>>>>> I'm very new to Ambari. I just downloaded the source from the SVN
and
>>>>>> when
>>>>>> I tried a maven build I got the following errors:
>>>>>>
>>>>>>
>>>>>> [INFO] ------------------------------******--------------------------*
>>>>>> *--**
>>>>>>
>>>>>> --**
>>>>>>
>>>>>> ------------
>>>>>> [INFO] Reactor Summary:
>>>>>> [INFO]
>>>>>> [INFO] Ambari Main ..............................******.........
>>>>>> SUCCESS
>>>>>>
>>>>>>
>>>>>> [3.669s]
>>>>>> [INFO] Apache Ambari Project POM ......................... SUCCESS
>>>>>> [0.028s]
>>>>>> [INFO] Ambari Web ..............................******..........
>>>>>> FAILURE
>>>>>> [1.895s]
>>>>>> [INFO] Ambari Server ..............................******.......
>>>>>> SKIPPED
>>>>>> [INFO] Ambari Agent ..............................******........
>>>>>> SKIPPED
>>>>>> [INFO] ------------------------------******--------------------------*
>>>>>> *--**
>>>>>>
>>>>>> --**
>>>>>> ------------
>>>>>> [INFO] BUILD FAILURE
>>>>>> [INFO] ------------------------------******--------------------------*
>>>>>> *--**
>>>>>>
>>>>>> --**
>>>>>>
>>>>>> ------------
>>>>>> [INFO] Total time: 6.950s
>>>>>> [INFO] Finished at: Mon Feb 18 11:00:14 CST 2013
>>>>>> [INFO] Final Memory: 4M/9M
>>>>>> [INFO] ------------------------------******--------------------------*
>>>>>> *--**
>>>>>> --**
>>>>>> ------------
>>>>>> [ERROR] Failed to execute goal org.apache.maven.plugins:****
>>>>>>
>>>>>> maven-antrun-plugin:1.7:run
>>>>>>
>>>>>> (compile) on project ambari-web: An Ant BuildException has occured:
>>>>>> Execute
>>>>>> failed: java.io.IOException: Cannot run program "npm" (in directory
>>>>>> "D:\workspace-ambari\trunk\******ambari-web"): CreateProcess error=2,
>>>>>> The
>>>>>>
>>>>>>
>>>>>> system cannot find the file specified
>>>>>> [ERROR] around Ant part ...<exec dir="D:\workspace-ambari\****
>>>>>>
>>>>>> trunk\ambari-web"
>>>>>>
>>>>>> executable="npm" failonerror="false">... @ 4:89 in
>>>>>> D:\workspace-ambari\trunk\******ambari-web\target\antrun\**
>>>>>>
>>>>>>
>>>>>> build-ambari-web-compile.xml
>>>>>> [ERROR] ->   [Help 1]
>>>>>> [ERROR]
>>>>>> [ERROR]
>>>>>> [ERROR] To see the full stack trace of the errors, re-run Maven with
>>>>>> the
>>>>>> -e switch.
>>>>>> [ERROR] Re-run Maven using the -X switch to enable full debug logging.
>>>>>> [ERROR]
>>>>>> [ERROR] For more information about the errors and possible solutions,
>>>>>> please read the following articles:
>>>>>> [ERROR] [Help 1] http://cwiki.apache.org/******
>>>>>> confluence/display/MAVEN/**<http://cwiki.apache.org/****confluence/display/MAVEN/**>
>>>>>> <ht**tp://cwiki.apache.org/****confluence/display/MAVEN/**<http://cwiki.apache.org/**confluence/display/MAVEN/**>
>>>>>>>
>>>>>> MojoExecutionException<http://****cwiki.apache.org/confluence/****<http://cwiki.apache.org/confluence/**>
>>>>>> display/MAVEN/****MojoExecutionException<http://**
>>>>>> cwiki.apache.org/confluence/**display/MAVEN/**MojoExecutionException<http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException>
>>>>>>>
>>>>>>
>>>>>>
>>>>>>>
>>>>>> [ERROR]
>>>>>> [ERROR] After correcting the problems, you can resume the build with
>>>>>> the
>>>>>> command
>>>>>> [ERROR]   mvn<goals>   -rf :ambari-web
>>>>>> ------------------------------******--------------------------**--**
>>>>>>
>>>>>> --**---------
>>>>>>
>>>>>>
>>>>>> Any idea whats going on here? I followed all the instructions written
>>>>>> in
>>>>>> https://cwiki.apache.org/******confluence/display/AMBARI/**<https://cwiki.apache.org/****confluence/display/AMBARI/**>
>>>>>> <h**ttps://cwiki.apache.org/****confluence/display/AMBARI/**<https://cwiki.apache.org/**confluence/display/AMBARI/**>
>>>>>>>
>>>>>> Coding+Guidelines+for+Ambari<**h**ttps://cwiki.apache.org/**
>>>>>> confluence/display/AMBARI/****Coding+Guidelines+for+Ambari<h**
>>>>>> ttps://cwiki.apache.org/**confluence/display/AMBARI/**
>>>>>> Coding+Guidelines+for+Ambari<https://cwiki.apache.org/confluence/display/AMBARI/Coding+Guidelines+for+Ambari>
>>>>>>>
>>>>>>
>>>>>>> **and have installed NodeJS and brunch. But still facing the
above
>>>>>>>
>>>>>> error.
>>>>>>
>>>>>>
>>>>>>
>>>>>> Any information will be highly appreciated.
>>>>>>
>>>>>>
>>>>>>
>>>>>> Thanks in advance.
>>>>>> Tanzir
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>
>>>
>>
>> --
>> Paulo Ricardo Paz Vital, Staff Software Engineer
>> Linux Technology Center, IBM Systems&  Technology Group
>> ------------------------------**-------------------------
>> IBM
>> Rodovia SP101, km9 - ZIP: 13186-900
>> Hortolândia, SP - Brazil
>> Phone: +55-19-2132-2336
>> e-mail: pvital@linux.vnet.ibm.com
>> http://www.ibm.com/linux/ltc
>>
>>
>


-- 
Paulo Ricardo Paz Vital, Staff Software Engineer
Linux Technology Center, IBM Systems & Technology Group
-------------------------------------------------------
IBM
Rodovia SP101, km9 - ZIP: 13186-900
Hortolândia, SP - Brazil
Phone: +55-19-2132-2336
e-mail: pvital@linux.vnet.ibm.com
http://www.ibm.com/linux/ltc


Mime
View raw message