incubator-ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Siddharth Wagle (JIRA)" <j...@apache.org>
Subject [jira] [Created] (AMBARI-1082) Nagios install fails on SLES with incompatible nagios plugins
Date Fri, 14 Dec 2012 00:54:11 GMT
Siddharth Wagle created AMBARI-1082:
---------------------------------------

             Summary: Nagios install fails on SLES with incompatible nagios plugins
                 Key: AMBARI-1082
                 URL: https://issues.apache.org/jira/browse/AMBARI-1082
             Project: Ambari
          Issue Type: Bug
          Components: agent
    Affects Versions: 1.2.0
            Reporter: Siddharth Wagle
            Priority: Blocker


{noformat}

plugins]/Hdp::Package::Process_pkg[nagios-plugins]/Package[nagios-plugins-1.4.9]/ensure: change
from absent to present failed: Execution of '/usr/bin/zypper --quiet install -l -y nagios-plugins-1.4.9'
returned 4: Problem: cannot install both nagios-plugins-1.4.13-1.37.1.x86_64 and nagios-plugins-1.4.9-1.x86_64\n
Solution 1: Following actions will be done:\n  downgrade of nagios-plugins-1.4.13-1.37.1.x86_64
to nagios-plugins-1.4.9-1.x86_64\n  install nagios-plugins-1.4.9-1.x86_64 (with vendor change)\n
   SUSE LINUX Products GmbH, Nuernberg, Germany  -->  Nagios Plugin Development Group\n
Solution 2: do not ask to install a solvable providing nagios-plugins = 1.4.9\n\nChoose from
above solutions by number or cancel [1/2/c] (c): c\n\nnotice: /Stage[2]/Hdp-nagios::Server::Packages/Hdp-nagios::Server::Package[nagios-plugins]/Hdp::Package[nagios-plugins]/Hdp::Package::Process_pkg[nagios-plugins]/Anchor[hdp::package::nagios-plugins::end]:
Dependency Package[nagios-plugins-1.4.9] has failures: true\nwarning: /Stage[2]/Hdp-nagios::Server::Packages/Hdp-nagios::Server::Package[nagios-plugins]/Hdp::Package[nagios-plugins]/Hdp::Package::Process_pkg[nagios-plugins]/Anchor[hdp::package::nagios-plugins::end]:
Skipping because of failed dependencies\nnotice: /Stage[2]/Hdp-nagios::Server::Packages/Hdp-nagios::Server::Package[nagios-addons]/Hdp::Package[nagios-addons]/Hdp::Package::Process_pkg[nagios-addons]/Anchor[hdp::package::nagios-addons::begin]:
Dependency Package[nagios-plugins-1.4.9] has failures: true\nwarning: /Stage[2]/Hdp-nagios::Server::Packages/Hdp-nagios::Server::Package[nagios-addons]/Hdp::Package[nagios-addons]/Hdp::Package::Process_pkg[nagios-addons]/Anchor[hdp::package::nagios-addons::begin]:
Skipping because of failed dependencies\nnotice: /Stage[2]/Hdp-nagios::Server::Packages/Hdp-nagios::Server::Package[nagios-addons]/Hdp::Package[nagios-addons]/Hdp::Package::Process_pkg[nagios-addons]/Package[hdp_mon_nagios_addons]:
Dependency Package[nagios-plugins-1.4.9] has failures: true\nwarning: /Stage[2]/Hdp-nagios::Server::Packages/Hdp-nagios::Server::Package[nagios-addons]/Hdp::Package[nagios-addons]/Hdp::Package::Process_pkg[nagios-addons]/Package[hdp_mon_nagios_addons]:
Skipping because of failed dependencies\nnotice: /Stage[2]/Hdp-nagios::Server::Packages/Hdp-nagios::Server::Package[nagios-addons]/Hdp::Package[nagios-addons]/Hdp::Package::Process_pkg[nagios-addons]/Anchor[hdp::package::nagios-addons::end]:
Dependency Package[nagios-plugins-1.4.9] has failures: true\nwarning: /Stage[2]/Hdp-nagios::Server::Packages/Hdp-nagios::Server::Package[nagios-addons]/Hdp::Package[nagios-addons]/Hdp::Package::Process_pkg[nagios-addons]/Anchor[hdp::package::nagios-addons::end]:
Skipping because of failed dependencies\nnotice: /Stage[2]/Hdp-nagios::Server::Packages/Anchor[hdp-nagios::server::packages::end]:
Dependency Package[nagios-plugins-1.4.9] has failures: true\nwarning: /Stage[2]/Hdp-nagios::Server::Packages/Anchor[hdp-nagios::server::packages::end]:
Skipping because of failed dependencies\nnotice: /Stage[2]/Hdp-nagios::Server/Hdp::Directory[/etc/nagios]/File[/etc/nagios]:
Dependency Package[nagios-plugins-1.4.9] has failures: true\nwarning: /Stage[2]/Hdp-nagios::Server/Hdp::Directory[/etc/nagios]/File[/etc/nagios]:
Skipping because of failed dependencies\nnotice: /Stage[2]/Hdp-nagios::Server/Hdp::Directory[/usr/lib64/nagios/plugins]/File[/usr/lib64/nagios/plugins]:
Dependency Package[nagios-plugins-1.4.9] has failures: true\nwarning: /Stage[2]/Hdp-nagios::Server/Hdp::Directory[/usr/lib64/nagios/plugins]/File[/usr/lib64/nagios/plugins]:
Skipping because of failed dependencies\nnotice: /Stage[2]/Hdp-nagios::Server/Hdp::Directory_recursive_create[/var/run/nagios]/Hdp::Exec[mkdir
-p /var/run/nagios]/Anchor[hdp::exec::mkdir -p /var/run/nagios::begin]: Dependency Package[nagios-plugins-1.4.9]
has failures: true\nwarning: /Stage[2]/Hdp-nagios::Server/Hdp::Directory_recursive_create[/var/run/nagios]/Hdp::Exec[mkdir
-p /var/run/nagios]/Anchor[hdp::exec::mkdir -p /var/run/nagios::begin]: Skipping because of
failed dependencies\nnotice: /Stage[2]/Hdp-nagios::Server/Hdp::Directory_recursive_create[/var/run/nagios]/Hdp::Exec[mkdir
-p /var/run/nagios]/Exec[mkdir -p /var/run/nagios]: Dependency Package[nagios-plugins-1.4.9]
has failures: true\nwarning: /Stage[2]/Hdp-nagios::Server/Hdp::Directory_recursive_create[/var/run/nagios]/Hdp::Exec[mkdir
-p /var/run/nagios]/Exec[mkdir -p /var/run/nagios]: Skipping because of failed dependencies\nnotice:
/Stage[2]/Hdp-nagios::Server/Hdp::Directory_recursive_create[/var/run/nagios]/Hdp::Exec[mkdir
-p /var/run/nagios]/Anchor[hdp::exec::mkdir -p /var/run/nagios::end]: Dependency Package[nagios-plugins-1.4.9]
has failures: true\nwarning: /Stage[2]/Hdp-nagios::Server/Hdp::Directory_recursive_create[/var/run/nagios]/Hdp::Exec[mkdir
-p /var/run/nagios]/Anchor[hdp::exec::mkdir -p /var/run/nagios::end]: Skipping because of
failed dependencies\nnotice: /Stage[2]/Hdp-nagios::Server/Hdp::Directory_recursive_create[/var/run/nagios]/Hdp::Directory[/var/run/nagios]/File[/var/run/nagio

{noformat}


--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message