incubator-ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Yusaku Sako (JIRA)" <j...@apache.org>
Subject [jira] [Created] (AMBARI-638) Weirdness with Custom Config page when the user goes back to previous stages
Date Mon, 16 Jul 2012 23:57:34 GMT
Yusaku Sako created AMBARI-638:
----------------------------------

             Summary: Weirdness with Custom Config page when the user goes back to previous
stages
                 Key: AMBARI-638
                 URL: https://issues.apache.org/jira/browse/AMBARI-638
             Project: Ambari
          Issue Type: Bug
    Affects Versions: 0.9.0
            Reporter: Yusaku Sako
            Assignee: Yusaku Sako
             Fix For: 0.9.0, 1.0


Issue 1.  Going back and forth between different stages in the Cluster Install Wizard, it
is possible to get into a state where Custom Config form has the submit button disabled but
no field errors are shown.

Steps to replicate:

 * Go up to Stage 6, but do not submit the form
 * Go back to Stage 3
 * Go up to Stage 6 again. No field errors are shown when they should be.


Issue 2.  Custom Config stage is skipped once you get to "Review and Deploy" and go back to
a stage preceding Custom Config.

Steps to replicate:

 * Go thru the Cluster Install Wizard up to Stage 7 ("Review and Deploy"), but do not submit
the form.
 * Go back to Stage 4 or 5. Once you submit the form on Stage 5, Stage 6 is skipped and goes
directly to Stage 7.
 * If you go back to Stage 3 or earlier, then Stage 6 will not be skipped.




--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message