incubator-allura-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dave Brondsema <d...@brondsema.net>
Subject Re: Build failed in Jenkins: Allura #97
Date Wed, 03 Jul 2013 14:22:09 GMT
We've had a few failures due to python-svn not being installed.  It looked like
it was only on the "ubuntu2" slave so I reopened the INFRA ticket I had made to
originally install python-svn on the jenkins ubuntu slaves.  It's installed now
so I think this failure should be history.

Some other failures recently were pypi access issues.  As a few of us discussed
on IRC, just retrying the `pip install` command would probably be sufficient.  I
configured it to retry twice with 10 second sleep between runs.  That seems to
be be working so far.

On 7/2/13 11:12 PM, Apache Jenkins Server wrote:
> See <https://builds.apache.org/job/Allura/97/>
> 
> ------------------------------------------
> [...truncated 1800 lines...]
>   File "/home/hudson/jenkins-slave/workspace/Allura/.allura-venv/local/lib/python2.7/site-packages/nose/case.py",
line 381, in setUp
>     try_run(self.inst, ('setup', 'setUp'))
>   File "/home/hudson/jenkins-slave/workspace/Allura/.allura-venv/local/lib/python2.7/site-packages/nose/util.py",
line 478, in try_run
>     return func()
>   File "/home/hudson/jenkins-slave/workspace/Allura/ForgeSVN/forgesvn/tests/functional/test_controllers.py",
line 39, in setUp
>     self.setup_with_tools()
>   File "/home/hudson/jenkins-slave/workspace/Allura/Allura/allura/tests/decorators.py",
line 63, in wrapped
>     c.app = p.install_app(ep_name, mount_point, mount_label, ordinal, **override_options)
>   File "/home/hudson/jenkins-slave/workspace/Allura/Allura/allura/model/project.py",
line 573, in install_app
>     App = g.entry_points['tool'][ep_name]
>   File "/home/hudson/jenkins-slave/workspace/Allura/Allura/allura/lib/utils.py", line
389, in __getitem__
>     return self.store[self.__keytransform__(key)]
> KeyError: u"'svn'\n-------------------- >> begin captured stdout << ---------------------\nRunning
setup_app() from allura.websetup\n\n--------------------- >> end captured stdout <<
----------------------"
> 



-- 
Dave Brondsema : dave@brondsema.net
http://www.brondsema.net : personal
http://www.splike.com : programming
              <><

Mime
View raw message