incubator-agila-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matthieu Riou" <matthieu.r...@gmail.com>
Subject Re: login problem
Date Sat, 18 Feb 2006 18:49:30 GMT
Could you describe your environment a bit further? JDK version, the
database you're using, any specificities in your classpath? This
normally shouldn't happen so it's specific to your environment.

On 2/18/06, Pierre Pönisch <pierre_poenisch@web.de> wrote:
> Hi Matthieu,
>
> thanks for your hint. I found one error in the output of "maven db:create":
>
> [...]
>     [java] 7296 [main] INFO persistence.DBSessionManager  - Commiting
> transaction with thread : Thread[main,5,main]
>     [java] Hibernate: select roleimpl0_.id as id, roleimpl0_.name as name
> from T_ROLE roleimpl0_ where (roleimpl0_.name=(?))
>     [java] 7406 [main] ERROR persistence.PersistentDataAccess  - Problem
> when updating a persistent object.
>     [java]
> org.apache.agila.bpel.engine.common.persistence.DBSessionException: No
> active persistence, the transaction has probably not been initialized in
> thread Thread[main,5,main]
>     [java]      at
> org.apache.agila.bpel.engine.common.persistence.DBSessionManager.getActiveSe
> ssion(DBSessionManager.java:129)
>     [java]      at
> org.apache.agila.bpel.engine.common.persistence.PersistentDataAccess.create(
> PersistentDataAccess.java:30)
>     [java]      at
> org.apache.agila.bpel.user.priv.AgilaUserImpl.createOrUpdatePO(AgilaUserImpl
> .java:394)
>     [java]      at
> org.apache.agila.bpel.user.priv.AgilaUserImpl.createRole(AgilaUserImpl.java:
> 73)
>     [java]      at
> org.apache.agila.bpel.util.SchemaCreator.initUsersRoles(SchemaCreator.java:4
> 9)
>     [java]      at
> org.apache.agila.bpel.util.SchemaCreator.createSchema(SchemaCreator.java:40)
>     [java]      at
> org.apache.agila.bpel.util.SchemaCreator.main(SchemaCreator.java:71)
>     [java]
> org.apache.agila.bpel.engine.common.persistence.CreationException:
> org.apache.agila.bpel.engine.common.persistence.DBRuntimeException:
> org.apache.agila.bpel.engine.common.persistence.DBSessionException: No
> active persistence, the transaction has probably not been initialized in
> thread Thread[main,5,main]
>     [java]      at
> org.apache.agila.bpel.user.priv.AgilaUserImpl.createRole(AgilaUserImpl.java:
> 75)
>     [java]      at
> org.apache.agila.bpel.util.SchemaCreator.initUsersRoles(SchemaCreator.java:4
> 9)
>     [java]      at
> org.apache.agila.bpel.util.SchemaCreator.createSchema(SchemaCreator.java:40)
>     [java]      at
> org.apache.agila.bpel.util.SchemaCreator.main(SchemaCreator.java:71)
>     [java] Caused by:
> org.apache.agila.bpel.engine.common.persistence.DBRuntimeException:
> org.apache.agila.bpel.engine.common.persistence.DBSessionException: No
> active persistence, the transaction has probably not been initialized in
> thread Thread[main,5,main]
>     [java]      at
> org.apache.agila.bpel.engine.common.persistence.PersistentDataAccess.create(
> PersistentDataAccess.java:37)
>     [java]      at
> org.apache.agila.bpel.user.priv.AgilaUserImpl.createOrUpdatePO(AgilaUserImpl
> .java:394)
>     [java]      at
> org.apache.agila.bpel.user.priv.AgilaUserImpl.createRole(AgilaUserImpl.java:
> 73)
>     [java]      ... 3 more
>     [java] Caused by:
> org.apache.agila.bpel.engine.common.persistence.DBSessionException: No
> active persistence, the transaction has probably not been initialized in
> thread Thread[main,5,main]
>     [java]      at
> org.apache.agila.bpel.engine.common.persistence.DBSessionManager.getActiveSe
> ssion(DBSessionManager.java:129)
>     [java]      at
> org.apache.agila.bpel.engine.common.persistence.PersistentDataAccess.create(
> PersistentDataAccess.java:30)
>     [java]      ... 5 more
> BUILD SUCCESSFUL
> Total time: 10 seconds
> Finished at: Sat Feb 18 16:15:11 CET 2006
>
> How can I fix this? Thanks!
> Pierre
>
> --
> Pierre Poenisch
> University of Technology Chemnitz, Germany
> Pierre.Poenisch@s2000.TU-Chemnitz.de
> Public Key: 0x82FB6ADE at keyserver.pgp.com
> Fingerprint: CB7F F23F D950 644D 838B  215A 550F 75EC 64D9 6827
>
> >-----Ursprüngliche Nachricht-----
> >Von: Matthieu Riou [mailto:matthieu.riou@gmail.com]
> >Gesendet: Samstag, 18. Februar 2006 14:19
> >An: agila-user@incubator.apache.org
> >Betreff: Re: login problem
> >
> >Hi Pierre,
> >
> >You probably had an error when creating the database schema.
> >Would you rerun the script and see if you have any error or
> >exception there?
> >
> >Thanks,
> >
> >Matthieu.
> >
> >On 2/18/06, Pierre Pönisch <pierre_poenisch@web.de> wrote:
> >> Hi!
> >>
> >> Today I have installed Agile for the first time. Twister 0.3 is also
> >> running on my WinXP machine.
> >>
> >> First of all I had a problem with maven. The file jcs-1.0-dev.jar
> >> could not be downloaded by maven, so I searched it by google and
> >> downloaded it by hand. After that I had to change my
> >build.properties
> >> and added the following two lines:
> >>
> >> maven.jar.override = on
> >> maven.jar.jcs = <path>\jcs-1.0-dev.jar
> >>
> >> Now the build with maven worked fine. I am sure there is an easier
> >> workaround for this, but it works. Maybe someone can fix that.
> >>
> >> After deploying Agila to Tomcat I get the following error when I try
> >> to log
> >> in:
> >>
> >> 2006-02-18 12:45:34,750 DEBUG http-8080-Processor25
> >> org.apache.agila.bpel.web.security.action.LoginAction -
> >Authenticating
> >> user admin
> >> 2006-02-18 12:45:34,796 INFO http-8080-Processor23
> >> org.apache.agila.bpel.user.priv.AgilaUserImpl - User with username
> >> admin couldn't be authenticated, user not found.
> >> 2006-02-18 12:45:34,828 DEBUG http-8080-Processor25
> >> org.apache.agila.bpel.web.security.action.LoginAction -
> >Authentication
> >> result false
> >> 2006-02-18 12:45:34,859 ERROR http-8080-Processor25
> >> org.apache.agila.bpel.web.security.action.LoginAction -
> >> org.apache.agila.bpel.user.exception.AgilaUserException:
> >>
> >org.apache.agila.bpel.engine.common.persistence.FinderException: User
> >> admin doesn't exists !
> >> AxisFault
> >>  faultCode:
> >> {http://schemas.xmlsoap.org/soap/envelope/}Server.userException
> >>  faultSubcode:
> >>  faultString:
> >org.apache.agila.bpel.user.exception.AgilaUserException:
> >>
> >org.apache.agila.bpel.engine.common.persistence.FinderException: User
> >> admin doesn't exists !
> >>  faultActor:
> >>  faultNode:
> >>  faultDetail:
> >>
> >> The database is running and I also created the schema.
> >>
> >> Some ideas about this? Thank you in advance for your help.
> >>
> >>
> >> --
> >> Pierre Poenisch
> >> University of Technology Chemnitz, Germany
> >> Pierre.Poenisch@s2000.TU-Chemnitz.de
> >> Public Key: 0x82FB6ADE at keyserver.pgp.com
> >> Fingerprint: CB7F F23F D950 644D 838B  215A 550F 75EC 64D9 6827
> >>
> >>
> >
>
>

Mime
View raw message