incubator-agila-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Glenn J Gonzales <ggonza...@exist.com>
Subject Re: Building and Installation Guide
Date Thu, 09 Jun 2005 10:15:50 GMT
Urgh, right I forgot... here it is :) Any thoughts on the errorMessage part?

Matthieu Riou wrote:

>>Isn't this because the deployment method
>>org.apache.agila.bpel.deployer.priv.AgilaDeployerImpl.deployDefinitions()
>>uses the bpel namespace
>>(http://schemas.xmlsoap.org/ws/2003/03/business-process/) to select the
>>property and propertyAlias nodes, as shown below?
>>
>>                469  XPath xpathSelector =
>>DocumentHelper.createXPath("//*/defaultNS:property[@name=\"" +
>>propertyName + "\"]");
>>                470  HashMap nsMap = new HashMap(1);
>>                471  nsMap.put("defaultNS", BPEL_NS);
>>                472  xpathSelector.setNamespaceURIs(nsMap);
>>                473  Node propNode = xpathSelector.selectSingleNode(doc);
>>    
>>
>
>Yes it is, property and propertyAlias must be declared in the BPEL
>namespace. The example1 has been a bit outdated. I'd like to apply
>your diff on the wsdef.xml but I think you forgot to attach it, right?
>
>  
>
>>Another thing, after having successfully deployed the process (after
>>editing wsdef.xml as above), I got a null pointer exception, as below
>>(I'm still looking into it):
>>    
>>
>
>Let me know if I can help you. You might have more trace in tomcat's log files.
>
>Cheers,
>
>Matthieu.
>
>  
>


-- 
Cheers,
Glenn

-------

Reclaim Your Inbox!
http://www.mozilla.org/products/thunderbird/


Mime
View raw message