incubator-adffaces-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Böhringer Jochen <Jochen.Boehrin...@tcc-products.de>
Subject Using Trinidad under Java 1.4?
Date Mon, 23 Apr 2007 18:03:00 GMT
Hello,

I am doing some research for a new project. It is a web application whose user interface should
be programmed using JSF. The application server we are running in the target environment is
WebSphere Application Server 5.1.
Unfortunately the latest JDK supported by this WebSphere version is 1.4.2 :-( 

The installation instructions of Trinidad do note Java 5 as a dependency.
So is this a showstopper for Trinidad in this project? Perhaps the only 1.5 features used
are generics and these can also be interpreted by a 1.4 jdk on bytecodelevel...

I have used Trinidad in other projects and would really like to use it again...

So my question in one sentence: Is it possible to run Trinidad on a 1.4 JDK with small amount
of adaptation or should I stop thinking about it immediately?

Best regards,
Jochen

 

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message