incubator-adffaces-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Luka Surija <luka.sur...@iytim.hr>
Subject Re: m1-incubating to 1.0.1-incubating broken client validator
Date Tue, 27 Mar 2007 07:59:23 GMT
Is there any chance that it will be fixed any time soon or is it some 
kind of feature that is not known to me?



Luka Surija wrote:
> Hello,
> after switching from m1 to 1.0.1. snapshot, I realize that client 
> validator for decimal numbers is broken.
>
> Settings in trinidad-config:
> <number-grouping-separator>.</number-grouping-separator>
> <decimal-separator>,</decimal-separator>
>
> In faces-config.xml:
> <locale-config>
>       <default-locale>hr_HR</default-locale>
>       <supported-locale>hr_HR</supported-locale>
>       <supported-locale>en</supported-locale>
> </locale-config>
>
>
> on code snippet:
>
> somevalue=7.54355
>
>
> Scenario 1:
> <tr:inputText value="#{somevalue}" >
>   <tr:convertNumber />
> </tr:inputText>
> <tr:commandButton />
>
> on value in inputText is shown: 7,54355, but clicking on button, alert 
> window is open with message:
> Form validation failures:
> 7.54355 is not a number
>
> Scenario 2:
> <tr:inputText value="#{somevalue}" />
> <tr:commandButton />
>
> on value in inputText is shown: 7.54355 - not 7,54355
>
> Scenario 3:
> <tr:inputText value="#{somevalue}" >
>   <tr:convertNumber  pattern="0.00####"/>
> </tr:inputText>
> <tr:commandButton />
>
> on value in inputText is shown: 7,54355, and there is no client 
> validation errors.
>
>
> On snapshot m1 it worked fine on "scenario 1".
>
> Regards
>
>
>


Mime
View raw message