incubator-adffaces-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chris Lowe" <chris.lowe...@gmail.com>
Subject Re: Re: Re: No Renderer found for component
Date Thu, 07 Dec 2006 22:59:33 GMT
Hi Adam,

I've made a post on the JBoss Seam forum to see if anyone else is having the
same problems as me.

http://www.jboss.com/index.html?module=bb&op=viewtopic&t=96786

Cheers,

C.

On 05/12/06, Chris Lowe <chris.lowe.uk@gmail.com> wrote:
>
> Would this definition of getRendererType() be a culprit for this?
>
> package org.jboss.seam.ui.tag;
>
> import ...;
>
> public class LinkTag extends HtmlOutputLinkTagBase
> {
>     @Override
>     public String getComponentType()
>     {
>         return HtmlLink.COMPONENT_TYPE;
>     }
>
>     @Override
>     public String getRendererType()
>     {
>         return null;
>     }
>
> ...
> }
>
> What should it be returning?  I'll try modding Seam.
>
> C.
>
>
> On 05/12/06, Chris Lowe <chris.lowe.uk@gmail.com> wrote:
> >
> > I'll do some digging on this.
> >
> > C.
> >
> > On 05/12/06, Adam Winer < awiner@gmail.com> wrote:
> > >
> > > I'd be curious to know how Seam registers the renderer for
> > > s:link.  If they're doing something a bit funky, it might
> > > cause these problems.
> > >
> > > -- Adam
> > >
> > >
> > >
> > > On 12/5/06, Chris Lowe < chris.lowe.uk@gmail.com> wrote:
> > > > Hi Adam,
> > > >
> > > > There is only output for the link.  I am using Seam's <s:link>
> > > component on
> > > > the pages that are generating this output.  This may be causing the
> > > output -
> > > > if so, is there anything that I need to configure?
> > > >
> > > > Cheers,
> > > >
> > > > Chris.
> > > >
> > > >
> > > >
> > > > On 05/12/06, Adam Winer < awiner@gmail.com > wrote:
> > > > >
> > > > > Nope, that looks right.
> > > > >
> > > > > Is it just:
> > > > >   component-family javax.faces.Output, renderer-type=
> > > javax.faces.Link
> > > > > ... or are there other component-family/renderer-type pairs
> > > > > that are having problems?
> > > > >
> > > > > -- Adam
> > > > >
> > > > >
> > > > > On 12/4/06, Chris Lowe < chris.lowe.uk@gmail.com> wrote:
> > > > > > Thanks for the reply Adam, my render kit in faces-config.xml
is
> > > defined
> > > > > as:
> > > > > >
> > > > > >     <application>
> > > > > >         <default-render-kit-id>org.apache.myfaces.trinidad.core
> > > > > > </default-render-kit-id>
> > > > > >     </application>
> > > > > >
> > > > > > Is there anything else that I need to do?
> > > > > >
> > > > > > Cheers,
> > > > > >
> > > > > > Chris.
> > > > > >
> > > > > > On 04/12/06, Adam Winer <awiner@gmail.com> wrote:
> > > > > > >
> > > > > > > Have you set the default-render-kit-id in your
> > > faces-config.xml
> > > > > > > to the Trinidad renderkit?
> > > > > > >
> > > > > > > -- Adam
> > > > > > >
> > > > > > >
> > > > > > > On 12/3/06, Chris Lowe < chris.lowe.uk@gmail.com>
wrote:
> > > > > > > > Hello All,
> > > > > > > >
> > > > > > > > I've just started to use the Trinidad component set
with
> > > Facelets
> > > > > 1.1.11
> > > > > > > /Seam
> > > > > > > > 1.1 and my pages now produce *lots* of output similar
to the
> > > > > following.
> > > > > > > > Could anyone tell me what I'm missing or need to do
in order
> > > to stop
> > > > > > > these
> > > > > > > > messages?
> > > > > > > >
> > > > > > > > 13:51:48,562 ERROR [STDERR] 03-Dec-2006 13:51:48
> > > > > > > >
> > > org.apache.myfaces.trinidadinternal.renderkit.RenderKitBasegetRenderer
> > > > > > > > WARNING: Renderer 'javax.faces.Link' not found for
component
> > > family
> > > > > '
> > > > > > > > javax.faces.Output'
> > > > > > > > 13:51:48,562 INFO  [[/ripuk]] No Renderer found for
> > > component
> > > > > > > > {Component-Path : [Class: javax.faces.component.UIViewRoot
> > > ,ViewId:
> > > > > > > > /view/public/order-format.xhtml][Class:
> > > > > > > > org.apache.myfaces.trinidad.component.html.HtmlBody
,Id:
> > > > > _id9][Class:
> > > > > > > > org.jboss.seam.ui.HtmlLink,Id: lnkTermsAndConditions]}
> > > > > > > (component-family=
> > > > > > > > javax.faces.Output, renderer-type=javax.faces.Link
)
> > > > > > > > 13:51:48,562 WARN  [UIComponentBase] No Renderer found
for
> > > component
> > > > > > > > {Component-Path : [Class: javax.faces.component.UIViewRoot
> > > ,ViewId:
> > > > > > > > /view/public/order- format.xhtml][Class:
> > > > > > > > org.apache.myfaces.trinidad.component.html.HtmlBody,Id:
> > > _id9][Class:
> > > > > > > > org.jboss.seam.ui.HtmlLink,Id: lnkTermsAndConditions]}
> > > > > > > (component-family=
> > > > > > > > javax.faces.Output, renderer-type=javax.faces.Link)
> > > > > > > >
> > > > > > > > Best Regards,
> > > > > > > >
> > > > > > > > Chris.
> > > > > > > >
> > > > > > > >
> > > > > > >
> > > > > >
> > > > > >
> > > > >
> > > >
> > > >
> > >
> >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message