incubator-adffaces-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matthias Wessendorf" <mat...@apache.org>
Subject Re: [Trinidad] h:commandButton not rendered
Date Wed, 20 Dec 2006 10:06:10 GMT
The issue is caused by HtmlCommandButtonRenderer (package
org.apache.myfaces.trinidadinternal.renderkit.htmlBasic)
that is used for <h:commandButton />.


I just committed a fix to svn, thx for catching this

-M

On 12/20/06, Renzo Tomaselli <renzo.tomaselli@tecnotp.it> wrote:
>
>  Well, just replacing "<h:commandButton value=..." by "<tr:commandButton
> text=" works fine for me, non a so huge change, but it was fairly surprising
> to discover how many things do not work anymore after reconfiguring for
> Trinidad, without any source change.
>
>  Renzo
>
>
>  Romanowski, Tim wrote:
>  It's funny that today we are running into the exact same problems. I
> had a thread going a while back about this problem, but supposedly it
> was patched in the trunk. Using a nightly from December 14, I am still
> having the same problem you are. When Trinidad is the renderkit, my
> buttons/images are not rendered...just the text as you are seeing.
> Interestingly enough, whatever the Trinidad renderkit is doing, it has
> fixed an outstanding bug I've had with Firefox in trying to display
> flash movies in my Facelets/JSF app.
>
>
>
> Adam or anyone else-does this "submit query text instead of an icon"
> problem ring a bell? Any suggestions?
>
>
>
> Tim
>
>
>
> ________________________________
>
> From: Renzo Tomaselli [mailto:renzo.tomaselli@tecnotp.it]
> Sent: Tuesday, December 19, 2006 1:56 PM
> To: adffaces-user@incubator.apache.org
> Subject: [Trinidad] h:commandButton not rendered
>
>
>
> Hi, I use a h:commandButton in a Facelet component, as:
>
>  <h:commandButton value="#{msg['login.login']}"
> action="#{loginBean.loginAction}"/>
>
> After reconfiguring the application to use Trinidad (without inserting
> any Trinidad component), the button (actually, *any* button), is not
> properly rendered. Actual rendering is:
>
> <input id="login:_id29" name="login:_id29" type="image"
> src="image;jsessionid=E8B45ABB8B070E3F0CC40CEBD813285C"
> onclick="submitForm('login',1,{source:'login:_id29'});return
> false;">
>
> Action works, but there is no value. Firefox displays "submit query"
> instead. I use the latest snapshot binaries.
> I also found a previous thread about this topic, but AFAIK there is no
> definitive answer.
> Thanks -- Renzo
>
>
>
>


-- 
Matthias Wessendorf
http://tinyurl.com/fmywh

further stuff:
blog: http://jroller.com/page/mwessendorf
mail: mwessendorf-at-gmail-dot-com

Mime
View raw message