incubator-adffaces-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matthias Wessendorf" <mat...@apache.org>
Subject Re: Problem with usesUpload attribute in form and encoding
Date Tue, 19 Dec 2006 14:58:21 GMT
k, lemme check.

one more question; is that guy in fron of the TrinidadFilter ?

Thx,
Matthias

On 12/19/06, Kunze, Anton <a.kunze@s2neueinformatik.de> wrote:
> Hello Matthias,
>
> I have configured the spring character encoding filter as first filter
> in web.xml, but encoding is incorrect.
>
> <filter>
>         <filter-name>CharacterEncodingFilter</filter-name>
>
> <filter-class>org.springframework.web.filter.CharacterEncodingFilter</fi
> lter-class>
>
>                 <init-param>
>                         <param-name>encoding</param-name>
>                         <param-value>UTF-8</param-value>
>                 </init-param>
>         </filter>
>
>         <filter-mapping>
>                 <filter-name>CharacterEncodingFilter</filter-name>
>                 <url-pattern>*.jsf</url-pattern>
>         </filter-mapping>
>
>         <filter-mapping>
>                 <filter-name>CharacterEncodingFilter</filter-name>
>                 <url-pattern>*.xhtml</url-pattern>
>         </filter-mapping>
>
>
> --
>
> Anton Kunze
> Entwicklung
>
> a.kunze@s2neueinformatik.de
> T: +49.40.80 81 69-630
> F: +49.40.80 81 69-808
>
> SinnerSchrader Neue Informatik
> >> Software. Design. Interfaces.
> http://www.s2neueinformatik.de/
>
>
> -----Original Message-----
> From: mwessendorf@gmail.com [mailto:mwessendorf@gmail.com] On Behalf Of
> Matthias Wessendorf
> Sent: Tuesday, December 19, 2006 3:15 PM
> To: adffaces-user@incubator.apache.org
> Subject: Re: Problem with usesUpload attribute in form and encoding
>
> Hello anton,
>
> are you using a filter in front of the faces servlet that queries the
> http parameter map ?
>
> In MyFaces the *FacesContextFactory* calls the setCharEncoding on the
> underlying request object. Doing a query before JSF (MyFaces) calls
> setCharEncoding will disable the this call.
>
> When using RI and Faclets this is not working:
> https://facelets.dev.java.net/issues/show_bug.cgi?id=190
>
> HTH,
> Matthias
>
> On 12/19/06, Kunze, Anton <a.kunze@s2neueinformatik.de> wrote:
> > Hello,
> >
> > I have a problem with encoding of german special characters after
> > submitting a trinidad form with attribute usesUpload="true". My
> Trinidad
> > form (myfaces, facelets, UTF-8) with several textfields and an
> inputFile
> > shows all characters correct. After a submit, all german special
> > characters in textfields are incorrect. If I set usesUpload to false
> > everything looks fine. What can I do?
> >
> > Best regards
> >
>
>
> --
> Matthias Wessendorf
> http://tinyurl.com/fmywh
>
> further stuff:
> blog: http://jroller.com/page/mwessendorf
> mail: mwessendorf-at-gmail-dot-com
>


-- 
Matthias Wessendorf
http://tinyurl.com/fmywh

further stuff:
blog: http://jroller.com/page/mwessendorf
mail: mwessendorf-at-gmail-dot-com

Mime
View raw message