incubator-adffaces-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Renzo Tomaselli <renzo.tomase...@tecnotp.it>
Subject [Trinidad] Tomahawk dataScroller not working
Date Thu, 21 Dec 2006 19:19:10 GMT
<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
  <meta content="text/html;charset=ISO-8859-1" http-equiv="Content-Type">
</head>
<body bgcolor="#ffffff" text="#000000">
<font size="+1">Hi, I wonder if anybody succeeded in getting
dataScroller working under Trinidad. Mine doesn't work anymore since I
updated my web.xml to Trinidad stuff.<br>
A dataScroller such as:<br>
<br>
&lt;t:dataScroller id="resultScroller" &nbsp;
actionListener="#{resultBean.paginator}" ....&gt;<br>
<br>
having a facet such as:<br>
<br>
&lt;f:facet name="next"&gt;<br>
&nbsp;&nbsp;&nbsp; &lt;h:panelGroup rendered="true"&gt;<br>
&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &lt;h:commandButton value="#{msg['result.scroller.next']}"
styleClass="nextPrevious" action="#{resultBean.apply}"/&gt;<br>
&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &lt;t:graphicImage url="#{sessionBean.map['arrow-next']}"
style="border: 1px""/&gt;<br>
&nbsp;&lt;/h:panelGroup&gt;<br>
&lt;/f:facet&gt;<br>
<br>
is rendered as:<br>
<br>
&lt;input id="_id50:result:_id409" name="_id50:result:_id409"
type="submit" value="next"<br>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
onclick="submitForm('_id50',1,{source:'_id50:result:_id409'});return
false;" class="nextPrevious"&gt;<br>
&lt;img src="/AxxBrowser/images/arrow-next.gif" style="border: 1px"&gt;<br>
&lt;a id="_id50:result:resultScrollernext"
name="_id50:result:resultScrollernext"<br>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
onclick="submitForm('_id50',1,{source:'_id50:result:resultScrollernext','_id50:result:resultScroller':'next'});return
false;"<br>
&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; class="OraLink"
href="#"&gt;&lt;/a&gt;<br>
<br>
the image element has no "onclick" attribute anymore, thus is not
active, unlike the non-Trinidad version.<br>
Furthermore, "next" button submits, but result is not as before (I'm
still investigating about this).<br>
Any idea ?<br>
Thanks -- Renzo<br>
<br>
</font>
</body>
</html>

Mime
View raw message