incubator-adffaces-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Renzo Tomaselli <renzo.tomase...@tecnotp.it>
Subject Re: [Trinidad] h:commandButton not rendered
Date Wed, 20 Dec 2006 08:59:03 GMT
<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
  <meta content="text/html;charset=ISO-8859-1" http-equiv="Content-Type">
</head>
<body bgcolor="#ffffff" text="#000000">
<font size="+1">Well, just replacing "&lt;h:commandButton value=..." by
"&lt;tr:commandButton text=" works fine for me, non a so huge change,
but it was fairly surprising to discover how many things do not work
anymore after reconfiguring for Trinidad, without any source change.<br>
<br>
Renzo<br>
</font><br>
Romanowski, Tim wrote:
<blockquote
 cite="mid635DFD17367AA04A92973AEB35F1141A2CDA1E@emss04m03.us.lmco.com"
 type="cite">
  <pre wrap="">It's funny that today we are running into the exact same problems.  I
had a thread going a while back about this problem, but supposedly it
was patched in the trunk.  Using a nightly from December 14, I am still
having the same problem you are.  When Trinidad is the renderkit, my
buttons/images are not rendered...just the text as you are seeing.
Interestingly enough, whatever the Trinidad renderkit is doing, it has
fixed an outstanding bug I've had with Firefox in trying to display
flash movies in my Facelets/JSF app.  

 

Adam or anyone else-does this "submit query text instead of an icon"
problem ring a bell?  Any suggestions?

 

Tim

 

________________________________

From: Renzo Tomaselli [<a class="moz-txt-link-freetext" href="mailto:renzo.tomaselli@tecnotp.it">mailto:renzo.tomaselli@tecnotp.it</a>]

Sent: Tuesday, December 19, 2006 1:56 PM
To: <a class="moz-txt-link-abbreviated" href="mailto:adffaces-user@incubator.apache.org">adffaces-user@incubator.apache.org</a>
Subject: [Trinidad] h:commandButton not rendered

 

Hi, I use a h:commandButton in a Facelet component, as:

        &lt;h:commandButton value="#{msg['login.login']}"
action="#{loginBean.loginAction}"/&gt;

After reconfiguring the application to use Trinidad (without inserting
any Trinidad component), the button (actually, *any* button), is not
properly rendered. Actual rendering is:

&lt;input id="login:_id29" name="login:_id29" type="image"
src="image;jsessionid=E8B45ABB8B070E3F0CC40CEBD813285C"
onclick="submitForm('login',1,{source:'login:_id29'});return false;"&gt;

Action works, but there is no value. Firefox displays "submit query"
instead. I use the latest snapshot binaries.
I also found a previous thread about this topic, but AFAIK there is no
definitive answer.
Thanks -- Renzo


  </pre>
</blockquote>
</body>
</html>

Mime
View raw message