incubator-adffaces-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Adam Winer" <awi...@gmail.com>
Subject Re: Dialog not popping-up
Date Mon, 18 Sep 2006 16:01:35 GMT
OK, I looked into this, at least on the Gecko family of browsers.  It works
fine
with partialSubmit="true" or "false", at least for me, but you do need to
have popup blockers either disabled globally or disabled for your
website.

What browser are you using?

-- Adam


On 9/17/06, Adam Winer <awiner@gmail.com> wrote:
>
> It shouldn't be necessary, but could you try setting partialSubmit="true"
> and see if that fixes it?  IIRC, there've been some reports of issues
> when partialSubmit isn't set.
>
> -- Adam
>
>
>
> On 9/15/06, andrew.w.wooster@gsk.com <andrew.w.wooster@gsk.com> wrote:
> >
> > I have not been able to get modal dialogs to pop-up.  I see them working
> > in the adf-faces-demo, but I cannot get them to work in my code.  Here's
> > what I'm doing:
> >
> > In Header.jsp:
> >   <af:form>
> >     <af:commandLink id="cmdLink" text="Lists"
> > action="dialog:ListCatalog"
> > useWindow="true"/>
> >   </af:form>
> >
> > In faces-config.xml:
> >   <navigation-rule>
> >     <navigation-case>
> >       <from-outcome>dialog:ListCatalog</from-outcome>
> >       <to-view-id>/portal/ListCatalog.jsp</to-view-id>
> >     </navigation-case>
> >   </navigation-rule>
> >
> > If I drop the "dialog:" prefix, the browser will redirect to
> > ListCatalog.jsp, but will not pop-up a new window.  What am I missing?
> > -Andrew
> >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message