incubator-adffaces-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steve Vangasse" <st...@boardshop.co.uk>
Subject MenuModel and navigationPane
Date Wed, 20 Sep 2006 15:14:10 GMT
Sorry. This is the subject I was supposed to use for my last post.


Steve Vangasse
www.boardshop.co.uk
----- Original Message ----- 
From: "Steve Vangasse" <steve@boardshop.co.uk>
To: <adffaces-user@incubator.apache.org>
Sent: Wednesday, September 20, 2006 4:11 PM
Subject: Re: ADF Faces v10 with NetBeans 5.5


> I'm using MenuModel navigation with a navigationTree component within the 
> "navigation3" facet of a panelPage component. This has been working fine 
> without any problems. Today I thought I would try using tabbed navigation 
> with my MenuModel using the "navigation1" facet and a navigationPane:
>
> <f:facet name="navigation1">
>    <af:navigationPane var="node" hint="tabs" value="#{menuModel.model}" 
> level="1">
>     <f:facet name="nodeStamp">
>      <af:commandNavigationItem text="#{node.label}" 
> action="#{node.getOutcome}"/>
>     </f:facet>
>    </af:navigationPane>
>   </f:facet>
>
> This doesn't seem to work. Clicking on a tab just refreshes the current 
> page without any error messages in my logs. I tried it with a hardcoded 
> action string that I know works elsewhere on the page and it still didn't 
> work. I then tried it with some hard coded child commandNavigationItems 
> without the MenuModel and it did work. Is there a problem with 
> navigationPanes and MenuModels (I'm running on the latest trinidad build 
> downloaded today)?
>
> Thanks,
>
> Steve Vangasse
> www.boardshop.co.uk
> 



Mime
View raw message