incubator-adffaces-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Simon_Less...@DMR.CA
Subject Re: Icons not appearing for SelectManyShuttle
Date Mon, 10 Jul 2006 14:09:22 GMT
Hello Jeantine,

You can find useful tutorial about custom skins at the following URLs:

http://www.oracle.com/technology/products/jdev/101/howtos/adfskins/index.html
http://www.oracle.com/technology/products/jdev/htdocs/partners/addins/exchange/jsf/doc/skin-selectors.html

As a small summary for your specific case, you have to:

1) Create an adf-faces-skin.xml file in the WEB-INF folder of your 
application with a format looking like
<?xml version="1.0" encoding="ISO-8859-1"?>

<skins xmlns="http://myfaces.apache.org/adf/view/faces/skin">
  <skin>
    <id>mySkin.desktop</id>
    <family>mySkin</family>
    <render-kit-id>org.apache.myfaces.adf.desktop</render-kit-id>
    <style-sheet-name>skins/mySkin/mySkin.css</style-sheet-name>
  </skin>
</skins>

2) Create a mySkin.css file in /skins/mySkin/

3) In that CSS, add the following selectors:
.AFShuttleMoveIcon:alias
.AFShuttleMoveAllIcon:alias
.AFShuttleRemoveIcon:alias
.AF ShuttleRemoveAllIcon:alias 

4) For each of those selectors, set the content property as a relative URL 
to the image you want to use. For example:
.AFShuttleMoveIcon:alias
{
  content: url('/skins/mySkin/skin_images/MyMoveIcon.gif');
}

5) Create the image file you want to use in the folder you specified in 
the selectors

6) In adf-faces-config.xml file (found in WEB-INF folder), set 
theskin-family property to your newly created skin. For example: 
<skin-family>mySkin</skin-family>


Regards,

Simon Lessard
Fujitsu Consulting





Jeantine Mankelow <jeantine@corp.peace.com>
2006-07-10 02:36
Please respond to adffaces-user
 
        To:     adffaces-user@incubator.apache.org
        cc: 
        Subject:        Icons not appearing for SelectManyShuttle


We have just started using the selectManyShuttle component, but the 
move/move-all/remove/remove-all icons are not showing up.

I had a go at debugging it and I can see that NullIcons are getting 
returned. It seems our skin is pointing to the minimal-desktop.xss, 
however I can't see any entry in this file for the shuttle component, 
nor in any of the other xss files in the same directory in the jar.  Any 
ideas why this doesn't work? 

Alternatively could someone tell me how I can extend the skin, so we can 
add our own icons for this component.

Thanks,
Jeantine


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message