incubator-adffaces-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Benj Fayle" <bfa...@maketechnologies.com>
Subject RE: Re: Re: Tag renaming proposal
Date Thu, 13 Jul 2006 23:14:31 GMT
Agreed which is why abbreviations such as inputLOV should be avoided
inputListOfValues is much more self-explanatory.

-----Original Message-----
From: Adam Winer [mailto:awiner@gmail.com] 
Sent: Wednesday, July 12, 2006 10:13 AM
To: adffaces-user@incubator.apache.org
Subject: Re: Re: Re: Tag renaming proposal

On 7/12/06, Mike Kienenberger <mkienenb@gmail.com> wrote:
>
> On 7/12/06, Matthias Wessendorf <matzew@apache.org> wrote:
> > > I've gotten a decent bit of feedback in the past that people
> > > just couldn't find selectInputDate or selectInputColor, but
> > > if they'd been called inputDate or inputColor, they would have
> > > been found.
> >
> > yes, that is true for me, to be honest .
>
> On the other hand, if someone explains up-front in the component table
> of contents that "input" meant unassisted entry and "select" meant
> assisted entry, and "inputSelect" means both, I could have figured
> this out.



... but as "selectInputDate", anyone looking alphabetically is just
totally
lost.

One of the goals of the renaming is to minimize any need for up-front
explanation;  the best name is one that requires no documentation.

-- Adam

Mime
View raw message