incubator-adffaces-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mike Kienenberger" <mkien...@gmail.com>
Subject Re: Re: Re: Tag renaming proposal
Date Wed, 12 Jul 2006 17:18:39 GMT
Somewhere the individual "learned" that "input" meant an input component.
All that's being suggested is that we also have people learn that
"select" is also an input component.

This appears to already be the case in general JSF nomenclature, but
until Simon's post, I never saw any explanation of the difference
between select and input.   If MyFaces/Tomahawk/Trinidad/Tobago start
using these naming conventions (the basic JSF components already are
doing so), I don't think it's a big deal that the input section and
the select section are in different spots on the component list.
You could always go with "inputSelect" for both if the "selectInput"
prefix is the only problem.

On 7/12/06, Adam Winer <awiner@gmail.com> wrote:
> On 7/12/06, Mike Kienenberger <mkienenb@gmail.com> wrote:
> >
> > On 7/12/06, Matthias Wessendorf <matzew@apache.org> wrote:
> > > > I've gotten a decent bit of feedback in the past that people
> > > > just couldn't find selectInputDate or selectInputColor, but
> > > > if they'd been called inputDate or inputColor, they would have
> > > > been found.
> > >
> > > yes, that is true for me, to be honest .
> >
> > On the other hand, if someone explains up-front in the component table
> > of contents that "input" meant unassisted entry and "select" meant
> > assisted entry, and "inputSelect" means both, I could have figured
> > this out.
>
>
>
> ... but as "selectInputDate", anyone looking alphabetically is just  totally
> lost.
>
> One of the goals of the renaming is to minimize any need for up-front
> explanation;  the best name is one that requires no documentation.
>
> -- Adam
>
>

Mime
View raw message