incubator-adffaces-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mike Kienenberger" <mkien...@gmail.com>
Subject Re: Re: Tag renaming proposal
Date Sun, 09 Jul 2006 17:20:34 GMT
On 7/8/06, Adam Winer <awiner@gmail.com> wrote:
> separator = <hr>, more or less.
> spacer takes up some space (horizontal, vertical, or both) with a blank
> area.
>
> Make sense?

Yeah, I would have guessed the same thing if pressed.

I'd suggest calling separator horizontalRule (or horizontalLine --
never quite understood the rule part since a rule is for making a
line, not the line itself) if that's what it is.


> > For reference, the name changes that had some concerns were:
> > > navigationPath      breadCrumbs
> > > navigationTrain     train
> >
> > I haven't used adffaces, so I don't know what either of these do.
> > However, the first set of names seem to imply it's something to do
> > with navigation (menus?).
>
>
> Page navigation, yes.
>
>    BreadCrumbs makes me think it's something
> > to do with cookies.    Train just draws a blank.   I have no idea what
> > a "train" component would be doing.
>
>
> Both of these are, in my experience at least, common names for
> two page navigation components;  the first commonly looking like:
>
>     Home > Shopping > Computers > MacBook Pro
>
> ... and the latter for multi-page wizards, like:
>
>    Shipping ---  Billing --- Payment -- Verify
>
> I don't know of other terms for these widgets.

I think you're saying that the navigationPath is a multilevel menu.
I'd stick with calling it a menu or menuPage or menuItem.

multipage Wizard makes perfect sense to me.   I think that's better than train.



> > > selectInputText     inputLOV
> >
> > inputListOfValues would be better than inputLOV.
>
>
> I could go either way.
>
> What's the difference between adf:inputText and adf:inputLOV?
> >
>
> It lets you pop up a dialog window (using the dialog framework) to pick a
> value,
> and have that value automatically entered into the field.  That requires a
> different base component class - more than just EditableValueHolder.

In that case, it'd probably make sense to stick popup in the name
somewhere.   inputTextPopup?  inputTextPopupList?   inputPopupList?

Mime
View raw message