incubator-adffaces-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mike Kienenberger" <>
Subject Re: Re: Tag renaming proposal
Date Sat, 08 Jul 2006 18:51:03 GMT
On 7/7/06, Adam Winer <> wrote:
> Old Name            New Name
> ------------------  ---------------
> decorateCollection  panelCollection
> navigationLevel     navigationPane
> objectIcon          icon
> objectImage         image
> objectMedia         media
> objectSeparator     separator
> objectSpacer        spacer
> panelBorder         panelBorderLayout
> panelForm           panelFormLayout
> panelGroup          panelGroupLayout
> panelHorizontal     panelHorizontalLayout
> selectInputColor    inputColor
> selectInputDate     inputDate
> showOneAccordion    panelAccordion
> showManyAccordion   panelAccordion (merge with showOneXyz)
> showOneChoice       panelChoice
> showOneRadio        panelRadio
> showOneTabs         panelTabbed

These seem clear to me, although I'm not sure what the difference
between a separator and a spacer are.

> For reference, the name changes that had some concerns were:
> navigationPath      breadCrumbs
> navigationTrain     train

I haven't used adffaces, so I don't know what either of these do.
However, the first set of names seem to imply it's something to do
with navigation (menus?).   BreadCrumbs makes me think it's something
to do with cookies.    Train just draws a blank.   I have no idea what
a "train" component would be doing.

And I am a native speaker :)

> selectInputText     inputLOV

inputListOfValues would be better than inputLOV.

What's the difference between adf:inputText and adf:inputLOV?

View raw message