incubator-adffaces-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matthias Wessendorf" <mat...@apache.org>
Subject Re: Tag renaming proposal
Date Thu, 27 Jul 2006 20:17:06 GMT
I updated the wiki page.

since most (or all) suggested inputListOfValues would be better than inputLOV

As Joseph already said, it's a love component ;)

-Matthias


On 7/27/06, Martin Marinschek <martin.marinschek@gmail.com> wrote:
> InputLove
>
> OutputLove
>
> SelectOneLove
>
> would all be great components for this ;)
>
> regards,
>
> Martin
>
> On 7/27/06, Matthias Wessendorf <matzew@apache.org> wrote:
> > On 7/27/06, Andrew Robinson <andrew.rw.robinson@gmail.com> wrote:
> > > Just to be a pain:  inputLOV -1
> > > Non-common acronym in a name just seems awful. Sounds like a control
> > > that you would use for online dating.
> >
> > :)
> >
> > thanks for the feedback!
> >
> > > On 7/27/06, Simon_Lessard@dmr.ca <Simon_Lessard@dmr.ca> wrote:
> > > > For a change I won't whine on anything and say +1 on those 3 as well !!!
> > > >
> > > > Simon Lessard
> > > > Fujitsu Consulting
> > > >
> > > >
> > > >
> > > >
> > > >
> > > >
> > > > "Matthias Wessendorf" <matzew@apache.org>
> > > > Sent by: mwessendorf@gmail.com
> > > > 2006-07-27 14:24
> > > > Please respond to adffaces-user
> > > >
> > > >         To:     adffaces-user@incubator.apache.org
> > > >         cc:
> > > >         Subject:        Re: Tag renaming proposal
> > > >
> > > >
> > > > <snip>
> > > > navigationPath      breadCrumbs
> > > > processTrain         train
> > > > selectInputText     inputLOV
> > > > </snip>
> > > >
> > > > +1 on all these three
> > > >
> > > > -Matthias
> > > >
> > > > On 7/25/06, Matthias Wessendorf <matzew@apache.org> wrote:
> > > > > fyi ...
> > > > >
> > > > > http://wiki.apache.org/myfaces/Trinidad_renaming
> > > > >
> > > > >
> > > > >
> > > > > On 7/25/06, Matthias Wessendorf <matzew@apache.org> wrote:
> > > > > > update...
> > > > > >
> > > > > > will do for sure:
> > > > > > decorateCollection  panelCollection
> > > > > > navigationLevel     navigationPane
> > > > > > objectIcon          icon
> > > > > > objectImage         image
> > > > > > objectMedia         media
> > > > > > objectSeparator     separator
> > > > > > objectSpacer        spacer
> > > > > > panelBorder         panelBorderLayout
> > > > > > panelForm           panelFormLayout
> > > > > > panelGroup          panelGroupLayout
> > > > > > panelHorizontal     panelHorizontalLayout
> > > > > > selectInputColor    inputColor
> > > > > > selectInputDate     inputDate
> > > > > > showOneAccordion    panelAccordion
> > > > > > showManyAccordion   panelAccordion (merge with showOneAccordion)
> > > > > > showOneChoice       panelChoice
> > > > > > showOneRadio        panelRadio
> > > > > > showOneTabs         panelTabbed
> > > > > >
> > > > > >
> > > > > > what was the result for:
> > > > > > navigationPath      breadCrumbs
> > > > > > navigationTrain     train
> > > > > > selectInputText     inputLOV
> > > > > >
> > > > > > I'd like to see breadCrumbs makes it. I noticed several requests
for
> > > > > > something like that (Forrest-list, myfaces-list (even from
> > > > > > non-natives)).
> > > > > >
> > > > > > inputLOV is more nice than its short form.
> > > > > >
> > > > > >
> > > > > > -Matthias
> > > > > >
> > > > > > On 7/14/06, Gabrielle Crawford <gabrielle.crawford@oracle.com>
wrote:
> > > > > > > I realize we're not doing these yet, but I thought I'd
mention for
> > > > later
> > > > > > > it's processTrain, not navigationTrain.
> > > > > > >
> > > > > > > http://incubator.apache.org/adffaces/tagdoc/af_processTrain.html
> > > > > > >
> > > > > > > Thanks,
> > > > > > >
> > > > > > > Gab
> > > > > > >
> > > > > > > Adam Winer wrote:
> > > > > > >
> > > > > > > > I'd like to get this wrapped up.  We had minor concerns
voiced
> > > > > > > > about a few of the changes, so I'm happy to temporarily
put
> > > > > > > > those on the back burner and revisit them afterwards,
but
> > > > > > > > does anyone have objections to the following list
of
> > > > > > > > name changes?
> > > > > > > >
> > > > > > > > Old Name            New Name
> > > > > > > > ------------------  ---------------
> > > > > > > > decorateCollection  panelCollection
> > > > > > > > navigationLevel     navigationPane
> > > > > > > > objectIcon          icon
> > > > > > > > objectImage         image
> > > > > > > > objectMedia         media
> > > > > > > > objectSeparator     separator
> > > > > > > > objectSpacer        spacer
> > > > > > > > panelBorder         panelBorderLayout
> > > > > > > > panelForm           panelFormLayout
> > > > > > > > panelGroup          panelGroupLayout
> > > > > > > > panelHorizontal     panelHorizontalLayout
> > > > > > > > selectInputColor    inputColor
> > > > > > > > selectInputDate     inputDate
> > > > > > > > showOneAccordion    panelAccordion
> > > > > > > > showManyAccordion   panelAccordion (merge with showOneXyz)
> > > > > > > > showOneChoice       panelChoice
> > > > > > > > showOneRadio        panelRadio
> > > > > > > > showOneTabs         panelTabbed
> > > > > > > >
> > > > > > > >
> > > > > > > > For reference, the name changes that had some concerns
were:
> > > > > > > >
> > > > > > > > navigationPath      breadCrumbs
> > > > > > > > navigationTrain     train
> > > > > > > > selectInputText     inputLOV
> > > > > > > >
> > > > > > > > -- Adam
> > > > > > > >
> > > > > > > >
> > > > > > > >
> > > > > > > > On 6/18/06, Adam Winer <awiner@gmail.com> wrote:
> > > > > > > >
> > > > > > > >> OK, so so far we've got some concern about:
> > > > > > > >>   - navigationPath -> breadCrumbs
> > > > > > > >>   - selectInputText -> inputLOV
> > > > > > > >>
> > > > > > > >> I'd also add that if we did decide not to rename
navigationPath,
> > > > > > > >> then I probably wouldn't want to move navigationTrain
-> train.
> > > > > > > >>
> > > > > > > >> FWIW, the issue with selectInputText is that we're
renaming
> > > > > > > >> "selectInputXyz" to "inputXyz" (seems like people
are very
> > > > > > > >> happy with that change for Color and Date), but
"inputText"
> > > > > > > >> is already filled, so we've gotta come up with
a different name.
> > > > > > > >>
> > > > > > > >> Any others?
> > > > > > > >>
> > > > > > > >> I think we can get some relatively quick consensus
about a subset
> > > > > > > >> of these suggestions that everyone likes, and
just do this up
> > > > front.
> > > > > > > >> Then we can hold off at last for a bit on changing
the ones that
> > > > have
> > > > > > > >> provoked some questions until we're mostly satisfied
with the set
> > > > that
> > > > > > > >> are left.
> > > > > > > >>
> > > > > > > >> -- Adam
> > > > > > > >>
> > > > > > > >>
> > > > > > > >>
> > > > > > > >>
> > > > > > > >>
> > > > > > > >>  On 6/18/06, Joseph Rozier <joseph.rozier@gmail.com>
wrote:
> > > > > > > >> > Martin and Matthias,
> > > > > > > >> >
> > > > > > > >> > LOV stands for "list of values".
> > > > > > > >> >
> > > > > > > >> > By the way, it seems that most people pronounce
it "L-O-V"
> > > > instead of
> > > > > > > >> > "love."  It took a few people laughing at
me from calling it
> > > > the "love
> > > > > > > >> > component" that got me to switch. :)
> > > > > > > >> >
> > > > > > > >> > Take care,
> > > > > > > >> >
> > > > > > > >> > Joey
> > > > > > > >> >
> > > > > > > >> > Martin Marinschek wrote:
> > > > > > > >> > > Breadcrumbs is an english expression
- you find your way with
> > > > > > > >> breadcrumbs,
> > > > > > > >> > > like in the fairy tale of "Hänsel and
Gretel" ;)
> > > > > > > >> > >
> > > > > > > >> > > LOV - I don't understand that either.
Me not being a native
> > > > english
> > > > > > > >> > speaker
> > > > > > > >> > > might be the reason.
> > > > > > > >> > >
> > > > > > > >> > > regards,
> > > > > > > >> > >
> > > > > > > >> > > Martin
> > > > > > > >> > >
> > > > > > > >> > > On 6/17/06, Ernst Fastl < ernst.fastl@gmail.com>
wrote:
> > > > > > > >> > >>
> > > > > > > >> > >> Great Idea!
> > > > > > > >> > >>
> > > > > > > >> > >> I also think that simpler names
would make it much easier to
> > > > get
> > > > > > > >> started.
> > > > > > > >> > >> although I don't really understand
"breadCrumbs" (maybe
> > > > stick to
> > > > > > > >> > >> navigationPath
> > > > > > > >> > >> or just path)  I think that the
other suggestions are really
> > > > great.
> > > > > > > >> > >>
> > > > > > > >> > >> Ernst
> > > > > > > >> > >>
> > > > > > > >> > >> On 6/16/06, Matthias Wessendorf
< matzew@apache.org> wrote:
> > > > > > > >> > >> > Hey-
> > > > > > > >> > >> >
> > > > > > > >> > >> > some comments inline.
> > > > > > > >> > >> >
> > > > > > > >> > >> > > been using a pretty rigorous
pattern:
> > > > > > > >> > >> > >
> > > > > > > >> > >> > > <component-family><Renderer-type>
> > > > > > > >> > >> > >
> > > > > > > >> > >> > > ... which is good for
JSF experts, but not necessarily
> > > > great
> > > > > > > >> for
> > > > > > > >> > >> > > first time users.
> > > > > > > >> > >> >
> > > > > > > >> > >> > :)
> > > > > > > >> > >> > I think the simpler the better
is a good approach. The
> > > > goal of
> > > > > > > >> > >> > Trinidad is not to address
only JSF experts. Since JSF
> > > > tries to
> > > > > > > >> > >> > simplify the "Java Web development"
our components should
> > > > have
> > > > > > > >> also
> > > > > > > >> > >> > simple names, however.
> > > > > > > >> > >> >
> > > > > > > >> > >> > > Some of the ideas to simplify
this:
> > > > > > > >> > >> > >
> > > > > > > >> > >> > > - Omit component-family
in some cases (esp. "object")
> > > > > > > >> > >> > > - Use supertype for component
families in others (esp.
> > > > > > > >> > >> > >      "input" instead of
"selectInput" and "panel"
> > > > instead of
> > > > > > > >> > >> > >      "showOne" or "decorate")
> > > > > > > >> > >> > > - Improve renderer-type
names (esp. add "Layout" to
> > > > > > > >> > >> > >    panels that perform
layout)
> > > > > > > >> > >> > > - Occasionally, just pick
names that are one-offs that
> > > > are
> > > > > > > >> clearer.
> > > > > > > >> > >> >
> > > > > > > >> > >> > removing "object" from "objectImage"
(for instance) is
> > > > > > > >> definitly a
> > > > > > > >> good
> > > > > > > >> > >> thing.
> > > > > > > >> > >> > Since some components perform
layout, a "Layout" should be
> > > > added!
> > > > > > > >> > >> > What to me was totally confusing
is the "selectInputDate".
> > > > > > > >> > >> >
> > > > > > > >> > >> > +1 on having these guys named
"inputDate". In a component
> > > > > > > >> palett I
> > > > > > > >> was
> > > > > > > >> > >> > always looking for inputDate
and then I figured out, that
> > > > guy is
> > > > > > > >> > >> > called selectInputDate.
> > > > > > > >> > >> >
> > > > > > > >> > >> >
> > > > > > > >> > >> > > Old Name            New
Name
> > > > > > > >> > >> > > ------------------  ---------------
> > > > > > > >> > >> > > decorateCollection  panelCollection
> > > > > > > >> > >> > > navigationLevel     navigationPane
> > > > > > > >> > >> > > navigationPath      breadCrumbs
> > > > > > > >> > >> > > navigationTrain     train
> > > > > > > >> > >> > > objectIcon          icon
> > > > > > > >> > >> > > objectImage         image
> > > > > > > >> > >> > > objectMedia         media
> > > > > > > >> > >> > > objectSeparator     separator
> > > > > > > >> > >> > > objectSpacer        spacer
> > > > > > > >> > >> > > panelBorder         panelBorderLayout
> > > > > > > >> > >> > > panelForm           panelFormLayout
> > > > > > > >> > >> > > panelGroup          panelGroupLayout
> > > > > > > >> > >> > > panelHorizontal     panelHorizontalLayout
> > > > > > > >> > >> > > selectInputColor    inputColor
> > > > > > > >> > >> > > selectInputDate     inputDate
> > > > > > > >> > >> > > selectInputText     inputLOV
> > > > > > > >> > >> > > showOneAccordion    panelAccordion
> > > > > > > >> > >> > > showManyAccordion   panelAccordion
(merge with
> > > > showOneXyz)
> > > > > > > >> > >> > > showOneChoice       panelChoice
> > > > > > > >> > >> > > showOneRadio        panelRadio
> > > > > > > >> > >> > > showOneTabs         panelTabbed
> > > > > > > >> > >> >
> > > > > > > >> > >> > what does the "LOV" by inputLOV
mean?
> > > > > > > >> > >> >
> > > > > > > >> > >> > The proposed names sounds reasonable.
> > > > > > > >> > >> > "breadCrumbs" is interesting.
> > > > > > > >> > >> >
> > > > > > > >> > >> > I guess Martin, Thomas and
Ernst will like their "Brösel".
> > > > > > > >> > >> >
> > > > > > > >> > >> > <German>
> > > > > > > >> > >> >    Or that guy who invented
the comic Werner :)
> > > > > > > >> > >> > </German>
> > > > > > > >> > >> >
> > > > > > > >> > >> > -Matthias
> > > > > > > >> > >> >
> > > > > > > >> > >> > > There's no deadline for
feedback, but sooner would be
> > > > > > > >> better. :)
> > > > > > > >> > >> > >
> > > > > > > >> > >> > > Thanks in advance,
> > > > > > > >> > >> > > Adam
> > > > > > > >> > >> > >
> > > > > > > >> > >> > >
> > > > > > > >> > >> >
> > > > > > > >> > >> >
> > > > > > > >> > >> > --
> > > > > > > >> > >> > Matthias Wessendorf
> > > > > > > >> > >> > Aechterhoek 18
> > > > > > > >> > >> > 48282 Emsdetten
> > > > > > > >> > >> > blog: http://jroller.com/page/mwessendorf
> > > > > > > >> > >> > mail: mwessendorf-at-gmail-dot-com
> > > > > > > >> > >> >
> > > > > > > >> > >>
> > > > > > > >> > >
> > > > > > > >> > >
> > > > > > > >> > >
> > > > > > > >> >
> > > > > > > >> >
> > > > > > > >>
> > > > > > > >>
> > > > > > >
> > > > > > >
> > > > > >
> > > > > >
> > > > > > --
> > > > > > Matthias Wessendorf
> > > > > >
> > > > > > further stuff:
> > > > > > blog: http://jroller.com/page/mwessendorf
> > > > > > mail: mwessendorf-at-gmail-dot-com
> > > > > >
> > > > >
> > > > >
> > > > > --
> > > > > Matthias Wessendorf
> > > > >
> > > > > further stuff:
> > > > > blog: http://jroller.com/page/mwessendorf
> > > > > mail: mwessendorf-at-gmail-dot-com
> > > > >
> > > >
> > > >
> > > > --
> > > > Matthias Wessendorf
> > > >
> > > > further stuff:
> > > > blog: http://jroller.com/page/mwessendorf
> > > > mail: mwessendorf-at-gmail-dot-com
> > > >
> > > >
> > > >
> > >
> >
> >
> > --
> > Matthias Wessendorf
> >
> > further stuff:
> > blog: http://jroller.com/page/mwessendorf
> > mail: mwessendorf-at-gmail-dot-com
> >
>
>
> --
>
> http://www.irian.at
>
> Your JSF powerhouse -
> JSF Consulting, Development and
> Courses in English and German
>
> Professional Support for Apache MyFaces
>


-- 
Matthias Wessendorf

further stuff:
blog: http://jroller.com/page/mwessendorf
mail: mwessendorf-at-gmail-dot-com

Mime
View raw message