incubator-adffaces-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Adam Winer" <awi...@gmail.com>
Subject Re: Re: Tag renaming proposal
Date Sat, 08 Jul 2006 21:02:10 GMT
On 7/8/06, Mike Kienenberger <mkienenb@gmail.com> wrote:
>
> On 7/7/06, Adam Winer <awiner@gmail.com> wrote:
> > Old Name            New Name
> > ------------------  ---------------
> > decorateCollection  panelCollection
> > navigationLevel     navigationPane
> > objectIcon          icon
> > objectImage         image
> > objectMedia         media
> > objectSeparator     separator
> > objectSpacer        spacer
> > panelBorder         panelBorderLayout
> > panelForm           panelFormLayout
> > panelGroup          panelGroupLayout
> > panelHorizontal     panelHorizontalLayout
> > selectInputColor    inputColor
> > selectInputDate     inputDate
> > showOneAccordion    panelAccordion
> > showManyAccordion   panelAccordion (merge with showOneXyz)
> > showOneChoice       panelChoice
> > showOneRadio        panelRadio
> > showOneTabs         panelTabbed
>
> These seem clear to me, although I'm not sure what the difference
> between a separator and a spacer are.


separator = <hr>, more or less.
spacer takes up some space (horizontal, vertical, or both) with a blank
area.

Make sense?

> For reference, the name changes that had some concerns were:
> > navigationPath      breadCrumbs
> > navigationTrain     train
>
> I haven't used adffaces, so I don't know what either of these do.
> However, the first set of names seem to imply it's something to do
> with navigation (menus?).


Page navigation, yes.

   BreadCrumbs makes me think it's something
> to do with cookies.    Train just draws a blank.   I have no idea what
> a "train" component would be doing.


Both of these are, in my experience at least, common names for
two page navigation components;  the first commonly looking like:

    Home > Shopping > Computers > MacBook Pro

... and the latter for multi-page wizards, like:

   Shipping ---  Billing --- Payment -- Verify

I don't know of other terms for these widgets.

And I am a native speaker :)
>
>
> > selectInputText     inputLOV
>
> inputListOfValues would be better than inputLOV.


I could go either way.

What's the difference between adf:inputText and adf:inputLOV?
>

It lets you pop up a dialog window (using the dialog framework) to pick a
value,
and have that value automatically entered into the field.  That requires a
different base component class - more than just EditableValueHolder.

Thanks for commenting;  it's useful getting feedback from people who
don't know the component set, since the biggest value of names is
in fact for those who don't know them yet.

-- Adam

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message