incubator-adffaces-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Adam Winer" <awi...@gmail.com>
Subject Tag renaming proposal
Date Fri, 16 Jun 2006 21:03:06 GMT
All,

Shortly before we got the source out, a proposal started circulating
internally to rename some of our tags to make them more intuitively
named and more obvious, especially to first time users.  We have
been using a pretty rigorous pattern:

<component-family><Renderer-type>

... which is good for JSF experts, but not necessarily great for
first time users.

Some of the ideas to simplify this:

- Omit component-family in some cases (esp. "object")
- Use supertype for component families in others (esp.
     "input" instead of "selectInput" and "panel" instead of
     "showOne" or "decorate")
- Improve renderer-type names (esp. add "Layout" to
   panels that perform layout)
- Occasionally, just pick names that are one-offs that are clearer.

That said, here's the list of proposed name changes.  I want
to emphasize that *ALL* of these are first-draft suggestions,
and I'd like as much input as possible on these names (and
others).  If you're a user and have found one of our component
names particularly baffling, let us know;  if you've found one
of the existing names perfect, but find the new name confusion,
let us know that too!

Old Name            New Name
------------------  ---------------
decorateCollection  panelCollection
navigationLevel     navigationPane
navigationPath      breadCrumbs
navigationTrain     train
objectIcon          icon
objectImage         image
objectMedia         media
objectSeparator     separator
objectSpacer        spacer
panelBorder         panelBorderLayout
panelForm           panelFormLayout
panelGroup          panelGroupLayout
panelHorizontal     panelHorizontalLayout
selectInputColor    inputColor
selectInputDate     inputDate
selectInputText     inputLOV
showOneAccordion    panelAccordion
showManyAccordion   panelAccordion (merge with showOneXyz)
showOneChoice       panelChoice
showOneRadio        panelRadio
showOneTabs         panelTabbed

There's no deadline for feedback, but sooner would be better. :)

Thanks in advance,
Adam

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message