incubator-adffaces-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Cosma Colanicchia" <cosma...@gmail.com>
Subject Re: Trying to attach AdfRenderingContext to a thread that already had one.
Date Mon, 29 May 2006 07:48:42 GMT
I have the very same problem, but I'm sure that I don't have the RI in
my classpath (as soon as my JDeveloper isn't adding it behind the
scenes).

Moreover, I also get this log at the end of every process:

29-mag-2006 9.45.48
org.apache.myfaces.adfinternal.renderkit.core.CoreRenderKit
encodeFinally
AVVERTENZA: No AdfRenderingContext available



2006/5/26, Adam Winer <awiner@gmail.com>:
> FWIW, I recently had exactly this issue, and it turned out that
> I had both the RI and MyFaces in my classpath.  Make sure you
> have only one or the other.
>
> -- Adam
>
>
> On 5/17/06, Arnaud MERGEY <amergey@sunopsis.com> wrote:
> > Hi, thanks for reply
> >
> > my faces-config.xml:
> > <?xml version="1.0" encoding="UTF-8"?>
> >
> > <!DOCTYPE faces-config PUBLIC
> >     "-//Sun Microsystems, Inc.//DTD JavaServer Faces Config 1.1//EN"
> >     "http://java.sun.com/dtd/web-facesconfig_1_1.dtd">
> >
> > <faces-config>
> >     <application>
> >         <default-render-kit-id>oracle.adf.core</default-render-kit-id>
> >     </application>
> >     <managed-bean>
> >         <description>test model for dataTable</description>
> >         <managed-bean-name>model</managed-bean-name>
> >         <managed-bean-class>
> >             com.sunopsis.lwd.model.TableModel
> >         </managed-bean-class>
> >         <managed-bean-scope>session</managed-bean-scope>
> >     </managed-bean>
> > </faces-config>
> >
> > Web.xml
> > <?xml version="1.0" encoding="UTF-8"?>
> > <web-app id="WebApp_ID" version="2.4"
> >     xmlns="http://java.sun.com/xml/ns/j2ee"
> >     xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
> >     xsi:schemaLocation="http://java.sun.com/xml/ns/j2ee
> > http://java.sun.com/xml/ns/j2ee/web-app_2_4.xsd">
> >     <display-name>Sunopsis JSF demo app</display-name>
> >
> >     <context-param>
> >         <param-name>javax.faces.STATE_SAVING_METHOD</param-name>
> >         <param-value>client</param-value>
> >     </context-param>
> >
> >     <filter>
> >         <filter-name>adfFaces</filter-name>
> >
> > <filter-class>oracle.adf.view.faces.webapp.AdfFacesFilter</filter-class>
> >     </filter>
> >
> >     <filter-mapping>
> >         <filter-name>adfFaces</filter-name>
> >         <servlet-name>FacesServlet</servlet-name>
> >     </filter-mapping>
> >
> >     <servlet>
> >         <servlet-name>FacesServlet</servlet-name>
> >         <servlet-class>javax.faces.webapp.FacesServlet</servlet-class>
> >         <load-on-startup>1</load-on-startup>
> >     </servlet>
> >
> >     <servlet-mapping>
> >         <servlet-name>FacesServlet</servlet-name>
> >         <url-pattern>*.faces</url-pattern>
> >     </servlet-mapping>
> >
> >     <servlet>
> >         <servlet-name>resources</servlet-name>
> >
> > <servlet-class>oracle.adf.view.faces.webapp.ResourceServlet</servlet-class>
> >         <load-on-startup>2</load-on-startup>
> >     </servlet>
> >
> >     <servlet-mapping>
> >         <servlet-name>resources</servlet-name>
> >         <url-pattern>/adf/*</url-pattern>
> >     </servlet-mapping>
> >
> >     <welcome-file-list>
> >         <welcome-file>index.html</welcome-file>
> >         <welcome-file>index.htm</welcome-file>
> >         <welcome-file>index.jsp</welcome-file>
> >         <welcome-file>default.html</welcome-file>
> >         <welcome-file>default.htm</welcome-file>
> >         <welcome-file>default.jsp</welcome-file>
> >     </welcome-file-list>
> > </web-app>
> >
> > Arnaud
> >
> > Adam Winer a écrit :
> > > The message itself isn't harmful, but it indicates a misconfiguration,
> > > probably a double-registration of something.  What does your
> > > faces-config.xml and web.xml look like?
> > >
> > > -- Adam
> > >
> > >
> > > On 5/17/06, Arnaud MERGEY <amergey@sunopsis.com> wrote:
> > >> Hi,
> > >> My JSF app is built with MyFaces 1.1.3 and ADF (apache-drop).
> > >> When I access to my pages, it is printed fine but tomcat (5.5.17) print
> > >> this log
> > >>
> > >> ATTENTION: Trying to attach AdfRenderingContext to a thread that already
> > >> had one.
> > >> 17 mai 2006 13:18:35
> > >> oracle.adfinternal.view.faces.renderkit.core.CoreRenderKit encodeFinally
> > >>
> > >> Can I ignore this message ?
> > >>
> > >> thanks,
> > >> Arnaud
> > >>
> > >
> >
> >
>

Mime
View raw message