incubator-adffaces-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Cosma Colanicchia" <cosma...@gmail.com>
Subject Re: Problems with sorting af:table
Date Mon, 29 May 2006 07:39:46 GMT
Hi Frank,

I played a bit with the page and now it works.. again, I don't know
exactly what was wrong (!) BTW it now works with <afh:body> and
<h:form>. I don't have <af:document>.

Thanks anyway for your help
Cosma



2006/5/26, Frank Felix Debatin <ffd@gmx.net>:
> Hi Cosma,
>
> try switching <afh:body> and <body> (or removing
> af:document) ... I have a similar problem that goes away
> when switching to <body>. According to Adam this turns of
> partial page rendering.
>
> Please let me know the outcome! It does not fix the bug, but
> at least we have a hint ...
>
> Frank Felix
>
>
>
> > -----Original Message-----
> > From: Cosma Colanicchia [mailto:cosmacol@gmail.com]
> > Sent: Friday, May 26, 2006 5:36 PM
> > To: ADF Faces Users ML
> > Subject: Problems with sorting af:table
> >
> > Hi,
> >
> > I'm working on a <af:table> component. I extended
> > CollectionModel to wrap my DAO object, and implemented the
>
> > isSortable, setSortCriteria and getSortCriteria to support
> sorting.
> >
> > It worked fine yesterday. Then I focused on the dialog
> > framework and other things... well, now sorting and paging
>
> > don't work anymore! When I click an header I can see the
> page
> > refresh but setSortCriteria isn't called. When I try to
> move
> > to the next page (using the "next" link or the dropdown
> list)
> > it does the same think: I see the submit, but the
> > setRowIndex/getRowData are always asking my
> CollectionModel
> > for the first page rows.
> >
> > I can't find why it doesn't work! Any ideas about where
> the
> > error could be?
> >
> > Thank you very much
> > Cosma
> >
>
>

Mime
View raw message