incubator-adffaces-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jeremy Sager" <jsa...@chessys.com>
Subject RE: Bug in ADF showOne components
Date Wed, 29 Mar 2006 16:52:36 GMT
By the way, I did my testing in firefox. In IE, I noticed that sometimes it
seems to sit at "loading" for great lengths of time instead of just
reverting.

Jeremy Sager
Data Communications Product Manager
Chesapeake System Solutions
410.356.6805 x120
JSager@chessys.com

-----Original Message-----
From: Jeremy Sager [mailto:jsager@chessys.com] 
Sent: Wednesday, March 29, 2006 11:45 AM
To: 'MyFaces Discussion'
Cc: adffaces-user@incubator.apache.org
Subject: Bug in ADF showOne components

Hi guys - 
 
I've researched this pretty thoroughly and I don't think this is a mistake
on my part. 
 
I'm worried that the general issue I'm demonstrating may extend beyond
showOne items, but they're all I've tested so far. The following bug is
demonstrated with showOneChoice, but I know for certain that it is also a
problem with showOneTab. I haven't tested it with other showOne components,
but am guessing we'll get similar results.
 
Basically, if you have a showOne component inside a form AND inside a facet,
it stops working properly. When you select an item from the showOne, it
automatically reverts back to the first item in the list no matter what you
selected.
 
I am certain this has nothing to do with the outputText component inside the
showDetailItem. I originally had different components in there, and only
substituted in the outputText because it's a simple small component that
makes testing easy.
 
Here is a sample setup:
 
<af:form>
      <af:panelBorder>
      <f:facet name="right">
            <af:showOneChoice position="top">
                  <af:showDetailItem text="Item One" id="_1234321" >
                        <af:outputText value="Showing One"/>
                  </af:showDetailItem>
                  <af:showDetailItem text="Item Two" id="_12345654321" >
                        <af:outputText value="Showing Two"/>
                  </af:showDetailItem>
            </af:showOneChoice>
      <f:facet>
      </af:panelBorder>
</af:form>
 
If you replace the panelBorder with a panelPage (i.e. another component with
a facet), you get the same behavior.
 
<af:form id="someform">
<af:panelPage id="_adasd">
<f:facet name="menu1">
<af:showOneChoice position="top">
<af:showDetailItem text="Item One" id="_1234321" >
<af:outputText value="Showing One" id="sdasda"/>
</af:showDetailItem>
<af:showDetailItem text="Item Two" id="_12345654321" >
<af:outputText value="Showing Two" id="asdsadads"/>
</af:showDetailItem>
</af:showOneChoice>
</f:facet>
</af:panelPage>
</af:form>
 
 
Remove the form, and everything works fine:     
            
<af:panelBorder>
<f:facet name="right">
      <af:showOneChoice position="top">
      <af:showDetailItem text="Item One" id="_1234321" >
            <af:outputText value="Showing One"/>
      </af:showDetailItem>
      <af:showDetailItem text="Item Two" id="_12345654321" >
            <af:outputText value="Showing Two"/>
      </af:showDetailItem>
      <af:showOneChoice>
      </f:facet>
</af:panelBorder>
                        
 
Keep the form, but pull the showOne item OUT of the facet, everything works
fine:   
 
                        
<af:form id="someform">
<af:panelPage id="_adasd">
<f:facet name="menu1">
<af:outputText value="Facet requires a tag" id="asdsadaddsadsas"/>
</f:facet>
<af:showOneChoice position="top">
<af:showDetailItem text="Item One" id="_1234321" >
<af:outputText value="Showing One" id="sdasda"/>
</af:showDetailItem>
<af:showDetailItem text="Item Two" id="_12345654321" >
<af:outputText value="Showing Two" id="asdsadads"/>
<af:showDetailItem>
</af:showOneChoice>
</af:panelPage>
</af:form>
 
It does not matter if the showOne item is a top level child of the facet or
not. This also fails:
 
<af:form id="someform">
<af:panelPage id="_adasd">
<f:facet name="menu1">
<af:panelBox id="box" text="header" background="medium">
<af:showOneChoice position="top">
<af:showDetailItem text="Item One" id="_1234321" >
<af:outputText value="Showing One" id="sdasda"/>
</af:showDetailItem>
<af:showDetailItem text="Item Two" id="_12345654321" >
<af:outputText value="Showing Two" id="asdsadads"/>
</af:showDetailItem>
</af:showOneChoice>
</af:panelBox>
</f:facet>        
</af:panelPage>
</af:form>
 
I'm going to do more testing to determine if there are other types of
components that misfire inside a facet inside a form, and I'll let you guys
know. In the meantime, hopefully the ADF guys who know the code can spot the
problem.
 
I don't think this is relevant to the issue, but in the interests of full
disclosure I am using facelets for my view handler.
 
I am on the nightlies for facelets, MyFaces, and ADF Faces as of Monday
3/27. however I know for certain that this bug was around in earlier
versions, because I upgraded in an attempt to fix the bug, and was
previously using MyFaces 1.1.1, the original ADF Faces drop, and whatever
version of facelets was out there in December '05.
 
I'm copying this to the myfaces list because the adffaces list just came up
yesterday and people who have something to add may not have signed up yet.
 
Jeremy Sager
Data Communications Product Manager
Chesapeake System Solutions
410.356.6805 x120
JSager@chessys.com


Mime
View raw message