incubator-adffaces-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christian Nolte (JIRA)" <adffaces-iss...@incubator.apache.org>
Subject [jira] Commented: (ADFFACES-111) HtmlGraphicImageTag creates wrong paths in url attribute
Date Fri, 04 Aug 2006 11:03:14 GMT
    [ http://issues.apache.org/jira/browse/ADFFACES-111?page=comments#action_12425722 ] 
            
Christian Nolte commented on ADFFACES-111:
------------------------------------------

Sorry then. But please, could you explain why the web-app directory is not prefixed within
any onmouse... attributes?

> HtmlGraphicImageTag creates wrong paths in url attribute
> --------------------------------------------------------
>
>                 Key: ADFFACES-111
>                 URL: http://issues.apache.org/jira/browse/ADFFACES-111
>             Project: MyFaces ADF-Faces
>          Issue Type: Bug
>         Environment: jboss 4.0.4, myfaces 1.1.3
>            Reporter: Christian Nolte
>         Attachments: graphicimage-test.war
>
>
> I have created an example JSP page containing the following myfaces tags:
> ---
> <f:view>
> 	<f:loadBundle basename="properties.test" var="bundle"/>
> 	<h:outputText value="#{bundle.imagepath}" />
> 	<h:graphicImage url="#{bundle.imagepath}" onmouseover="#{bundle.imagepath}" />
> 	<br>
> 	<h:outputText value="#{bundle.wrongimagepath}" />
> 	<h:graphicImage url="#{bundle.wrongimagepath}" onmouseover="#{bundle.wrongimagepath}"
/>
> </f:view>
> ---
> furthermore a properties.test file exists, containing the following entries:
> ---
> wrongimagepath=/images/ti_icon_test.png
> imagepath=images/ti_icon_test.png
> ---
> The rendered HTML-Code is the following:
> ---
> images/ti_icon_test.png
> <img src="images/ti_icon_test.png" onmouseover="images/ti_icon_test.png" />
> <br>
> /images/ti_icon_test.png
> <img src="/properties-test/images/ti_icon_test.png" onmouseover="/images/ti_icon_test.png"
/>
> ---
> As one can see, the path in the second <img>-tag is wrongly preceded by /properties-test
(the name of the war-file in this case). This behaviour is AFAIK unspecified. I guess that
the problem lies in impl.org.apache.myfaces.el.PropertyResolverImpl. A simple war-Archive
to test this matter is attached.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message