incubator-adffaces-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Scott O'Bryan" <darkar...@gmail.com>
Subject Re: partialTriggers and naming containers
Date Fri, 08 Dec 2006 18:14:51 GMT
Well in that case... +1  :)

Matthias Wessendorf wrote:
> feedback by all is welcome.
>
> a good community provides good code;
> that's Apache ;)
>
> -M
>
> On 12/8/06, Böhringer Jochen <Jochen.Boehringer@tcc-products.de> wrote:
>> I'm not a commiter, but I would also raise my hand for the
>>
>> "::" syntax.
>>
>> Regards
>> Jochen
>>
>> Von: venkata guddanti [mailto:venkata.guddanti@gmail.com]
>> Gesendet: Freitag, 8. Dezember 2006 18:07
>> An: adffaces-dev@incubator.apache.org
>> Betreff: Re: partialTriggers and naming containers
>>
>> +1 to "::" syntax.
>>
>> Can we also enhance the partialTriggers such that if we do not find a
>> component inside the naming container, we automatically look
>> for it using the parent component?
>>
>> Of course "::" syntax is more predictable.
>>
>> Regards,
>> Venkata
>>
>> On 12/8/06, Matthias Wessendorf <matzew@apache.org> wrote:
>> >
>> > > So, to fix this, I'd like to support some extra syntax like ".."
>> > > in file paths.  I'm thinking "::" to go up a level.  Maybe ":::"
>> > > to go up two, etc.?  So, partialTriggers="::first:foo" would work.
>> > >
>> > > How's this sound?
>> >
>> > Interesting idea. A ".." like approach for sorta navigation inside the
>> > component tree sounds good for me.
>> >
>> > I think the problem is the same with the for attribute (like on
>> > <message />) when refering to a UIComponent outside of the current NC.
>> >
>> > To make it short => +1
>> >
>> > -M
>> >
>> > > -- Adam
>> > >
>> >
>> >
>> > --
>> > Matthias Wessendorf
>> > http://tinyurl.com/fmywh
>> >
>> > further stuff:
>> > blog: http://jroller.com/page/mwessendorf
>> > mail: mwessendorf-at-gmail-dot-com
>> >
>>
>
>


Mime
View raw message