incubator-accumulo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Adam Fuchs <adam.p.fu...@ugov.gov>
Subject Re: 1.3.5 Master not listening on port
Date Thu, 08 Dec 2011 20:04:48 GMT
Yeah, you might have caught the repository in a bad state, or there might
have been a problem with your build. Hopefully rc10 will get approved and
we can move all the current users to an official build.

Cheers,
Adam


On Thu, Dec 8, 2011 at 2:36 PM, Trevor Adams <trevoradams@gmail.com> wrote:

> Adam,
>
> Using rc10, monitor reports the master is up and operational and I have
> confirmed that it is bound to the port 9999.
>
> Thanks,
> Trevor
>
>
> On Thu, Dec 8, 2011 at 2:33 PM, Trevor Adams <trevoradams@gmail.com>wrote:
>
>> I understand it would complain if something else is using it, it says
>> nothing regarding it on my system. If I run a netstat, nothing is listening
>> on 9999 after starting the master, and the monitor reports it failed to
>> find an available server in [localhost:9999] and the logs say nothing
>> regarding it.
>>
>> I am using localhost in the files, it is a single node cluster, and the
>> revision is: r1210579. I will try rc10 momentarily.
>>
>> -Trevor
>>
>>
>> On Thu, Dec 8, 2011 at 1:27 PM, Eric Newton <eric.newton@gmail.com>wrote:
>>
>>> In other words, I could not reproduce the problem... 1.3 complains
>>> pretty loudly that that it cannot bind to a socket.
>>>
>>> Make sure that you are using the same name in the masters and slaves
>>> files, either use the hostname, or use localhost (for a single node
>>> cluster), but don't mix and match.
>>>
>>> -Eric
>>>
>>>
>>> On Thu, Dec 8, 2011 at 1:17 PM, Eric Newton <eric.newton@gmail.com>wrote:
>>>
>>>> So, I just did this on my local machine with 1.3:
>>>>
>>>> # grab the master socket before accumulo starts:
>>>> $ python
>>>> >>> import socket as s
>>>> >>> sock = s.socket(s.AF_INET, s.SOCK_STREAM)
>>>> >>> sock.setsockopt(s.SOL_SOCKET, s.SO_REUSEADDR, 1)
>>>> >>> sock.bind(('', 9999))
>>>> >>> sock.listen(1000)
>>>>
>>>>  # new window: start accumulo
>>>> $ ./bin/start-all.sh
>>>>
>>>> # millions of lines like this in the master log:
>>>> 08 13:09:49,059 [util.TServerUtils] INFO : Unable to use port 9999,
>>>> retrying. (Thread Name = Master Client Service Handler)
>>>>
>>>> # it's safe to kill the master and rerun start-all:
>>>> $ pkill -f =master
>>>> $ ./bin/start-all.sh
>>>>
>>>> -Eric
>>>>
>>>>
>>>> On Thu, Dec 8, 2011 at 12:17 PM, Trevor Adams <trevoradams@gmail.com>wrote:
>>>>
>>>>>
>>>>>
>>>>> On Thu, Dec 8, 2011 at 12:10 PM, Trevor Adams <trevoradams@gmail.com>wrote:
>>>>>
>>>>>> Hello,
>>>>>>
>>>>>> I tried both with the 1.3 branch and the 1.3.5rc branch, both with
>>>>>> the same results. The master does not seem to be binding to 9999
(or any
>>>>>> port if I change it) nor is it logging that it couldn't bind or didn't
>>>>>> bind. The 1.4 branch binds just fine, however. So I am stumped on
this one.
>>>>>>
>>>>>>
>>>>>> Configuration:
>>>>>> I am running all of the servers on the same machine (it is a dev
vm),
>>>>>> mainly using the *.examples files.
>>>>>>
>>>>>> Thanks,
>>>>>> Trevor Adams
>>>>>>
>>>>>
>>>>>
>>>>
>>>
>>
>

Mime
View raw message