impala-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Arya Goudarzi <gouda...@gmail.com>
Subject Minidump Symboles are Not Resolving
Date Fri, 09 Feb 2018 04:06:46 GMT
Hi Team,

I am trying to troubleshoot a SIGSEGV crash we are getting with Impala 2.7
frequently. I followed the instructions here:

https://cwiki.apache.org/confluence/display/IMPALA/Debugging+Impala+Minidumps

However, it seems symboles are not resolving when I try to extract them
with minidump_stackwalk.

Here are the details:
CDH5.10.0
Impala 2.7 build 785a073cd07e2540d521ecebb8b38161ccbd2aa2

What I have done is the following:


   - clone Cloudera/Impala from github
   - checkout 785a073cd07e2540d521ecebb8b38161ccbd2aa2
   - ./configure
   - make
   - ./bin/dump_breakpad_symbols.py -b be/build/latest -d ~/impala-syms
   --dump_syms ./toolchain/breakpad-20150612-p1/bin/dump_syms
   - ./toolchain/breakpad-20150612-p1/bin/minidump_stackwalk
   ~/034329c7-9088-0fa3-3fb76e38-2f2208f5.dmp ~/impala-syms > ~/resolved.txt

However, symbols aren't resolved. If I look at the end of resolved.txt I
see this:
Loaded modules:
0x00400000 - 0x02830fff  impalad  ???  (main)  (WARNING: No symbols,
impalad, 51659402847B9CA647AB6C35F403A7EB0)
0x7f6071517000 - 0x7f6071725fff  libudfsample.64523.0.so  ???
0x7f60fd341000 - 0x7f60fd559fff  libresolv-2.19.so  ???
0x7f60fd55c000 - 0x7f60fd761fff  libnss_dns-2.19.so  ???
....

I have repeated the process many time to confirm I am not making a mistake
following the steps, but I might be missing something.

Your advise is greatly appreciated.

Cheers,
-Arya

Mime
View raw message