impala-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lars Volker ...@cloudera.com>
Subject Impalad fails to start after recent OS / Kernel upgrade
Date Tue, 27 Jun 2017 18:26:49 GMT
Hi All,

A recent patch to the Linux kernel
<https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=1be7107fbe18eed3e319a6c3e83c78254b693acb>
made
changes to the stack guard gap and results in Impalad failing to start its
JVM. If you recently upgraded your OS kernel or have automatic updates
enabled you may find error messages similar to the following during startup:

# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGBUS (0x7) at pc=0x00007f028e8e046f, pid=3044, tid=139649127274624


The effects on Impala are documented in IMPALA-5578
<https://issues.apache.org/jira/browse/IMPALA-5578>.

As a workaround you can pass a higher value of -Xss to the JVM by adding
this to your environment.

export JAVA_TOOL_OPTIONS="-Xss2m"


Alternatively you can pin the current kernel version to one before the
upgrade. Information on how to do so can be found here for apt-get
<https://help.ubuntu.com/community/PinningHowto> and here for yum
<https://access.redhat.com/solutions/98873>.

Let's use the JIRA for further discussion.

Cheers, Lars

Mime
View raw message