impala-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alexander Behm <alex.b...@cloudera.com>
Subject Re: Impala query seems doesn't return correct result when query after insert immediately.
Date Fri, 14 Apr 2017 15:37:47 GMT
Thanks for posting. What Impala version are you running? Is the issue
always reproducible? Are you behind a load balancer? Can you provide SHOW
CREATE TABLE or the involved tables?

Thanks!

Alex

On Fri, Apr 14, 2017 at 12:05 AM, 俊杰陈 <cjjnjust@gmail.com> wrote:

> Hi
> I met following strange issue, I insert a table from another table, and
> execute immediately, it shows wrong result.
> [bdpe822n2:21000] > insert into test.test5 select * from test.test2;
>
>  Query: insert into test.test5 select * from test.test2
> Query submitted at: 2017-04-14 14:21:53 (Coordinator:
> http://bdpe822n2:25000)
> Query progress can be monitored at: http://bdpe822n2:25000/query_
> plan?query_id=ba42eeb19d262dc6:c10ef07500000000
> Modified 16 row(s) in 5.22s
> [bdpe822n2:21000] > select * from test5;
> Query: select * from test5
> Query submitted at: 2017-04-14 14:22:05 (Coordinator:
> http://bdpe822n2:25000)
> Query progress can be monitored at: http://bdpe822n2:25000/query_
> plan?query_id=7c4ff772ce33f171:6933975300000000
> +----+------+----------+
> | id | name | progress |
> +----+------+----------+
> | 3  | jj   | 12.1     |
> | 3  | test | 15.3     |
> | 4  | jj   | 12.3     |
> | 2  | fs   | 15.2     |
> | 18 | jj   | 12.3     |
> | 13 | jj   | 12.3     |
> | 14 | jj   | 13.4     |
> | 2  | jj   | 12.1     |
> | 12 | jj   | 12.3     |
> | 6  | jj   | 12.3     |
> | 5  | jj   | 12.3     |
> | 20 | jj   | 12.3     |
> | 45 | jj   | 13.4     |
> | 15 | jj   | 15.5     |
> | 3  | jj   | 12.3     |
> | 1  | jj   | 23.5     |
> +----+------+----------+
> Fetched 16 row(s) in 0.18s
> [bdpe822n2:21000] > select * from test5 where id=3;
> Query: select * from test5 where id=3
> Query submitted at: 2017-04-14 14:22:13 (Coordinator:
> http://bdpe822n2:25000)
> Query progress can be monitored at: http://bdpe822n2:25000/query_
> plan?query_id=23432b5caf4b1ab4:9ade99c300000000
> +----+------+----------+
> | id | name | progress |
> +----+------+----------+
> | 3  | jj   | 12.3     |
> +----+------+----------+
> Fetched 1 row(s) in 0.18s
>
> However, after I restart the impala cluster, it can get correct result.
> Does anyone met issue like this? Should I need to run some synchronized
> command?
>
>
> --
> Thanks & Best Regards
>

Mime
View raw message