impala-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Armstrong <tarmstr...@cloudera.com>
Subject Re: impala setup issue
Date Thu, 15 Dec 2016 03:47:21 GMT
So buildall.sh failed? First you need to fix that failure - it means the
Python environment wasn't set up correctly.

There's probably an earlier warning like "Warning: Unable to download
Python requirements." - that's the error you need to fix if you want the
python tooling to work correctly.

On Wed, Dec 14, 2016 at 7:26 PM, 俊杰陈 <cjjnjust@gmail.com> wrote:

> Hi
>
>
>
> I’m trying to download impala and compile it but have some problems like
> following, can anyone help on this?
>
>
>
> ./buildall.sh complain  no virtualenv**.tag.gz found,  I tried download
> 15.1 version manually, while the impala-shell.sh can’t load sasl lib.  (
> I’m in Ubuntu 16.04, with GCC5.4 default, and I installed gcc4.9.2)
>
>
>
> Traceback (most recent call last):
>
>   File "/home/cjj/workspace/incubator-impala/shell/impala_shell.py", line
> 38, in <module>
>
>     from impala_client import (ImpalaClient, DisconnectedException,
> QueryStateException,
>
>   File "/home/cjj/workspace/incubator-impala/shell/impala_client.py",
> line 20, in <module>
>
>     import sasl
>
>   File "/home/cjj/workspace/incubator-impala/infra/python/env/
> local/lib/python2.7/site-packages/sasl/__init__.py", line 15, in <module>
>
>     from sasl.saslwrapper import *
>
> ImportError: /home/cjj/workspace/incubator-impala/infra/python/env/local/
> lib/python2.7/site-packages/sasl/saslw
>
> --
> Thanks & Best Regards
>

Mime
View raw message