impala-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jim Apple <jbap...@cloudera.com>
Subject Re: There is 5sec delay before actual execution when the table first time access
Date Thu, 24 Mar 2016 15:07:48 GMT
impala-user to bcc, user@apache to To:

You might want to check out
http://www.cloudera.com/documentation/enterprise/latest/topics/impala_refresh.html?scroll=refresh



On Wed, Mar 23, 2016 at 11:53 PM, 吴朱华 <ikewu83@gmail.com> wrote:

> I guess so, too^_^
> Is there anyway for reducing this latency?
>
> 2016-03-23 14:11 GMT+08:00 zhen <yyzzjj0515@gmail.com>:
>
>> I sure  time is spend on loading table metadata。  when first  access
>>  table , impala  fe sql parse should  loading table metadata backend  from
>> catalogd
>>
>> 在 2016年3月23日星期三 UTC+8上午11:53:09,吴朱华写道:
>>>
>>> thx,I have checked the profile, the time for profiles is less than one
>>> sec since the target table is small, the total is time is is more than
>>> 5sec. I am also beileve is metadata loading issues, and how can
>>> I troubleshoot this issue?^_^
>>>
>>> 2016-03-23 11:40 GMT+08:00 Dimitris Tsirogiannis <dtsiro...@cloudera.com
>>> >:
>>>
>>>> You may want to take a look at the profiles but my guess is that you're
>>>> seeing the latency of metadata loading the first time you're accessing your
>>>> table. Subsequent queries that access the same time find the metadata
>>>> loaded so they run faster. The profiles can help you verify that
>>>> hypothesis.
>>>>
>>>> Dimitris
>>>>
>>>> On Tue, Mar 22, 2016 at 8:32 PM, 吴朱华 <ike...@gmail.com> wrote:
>>>>
>>>>> Hi Guys:
>>>>>
>>>>> I have found a issue at my test cluster. There is 5sec delay before
>>>>> actual impalad execution when the table first time access, and this is
no
>>>>> delay when the table access after first try. Where is the potential
>>>>> misconfigure?
>>>>>
>>>>> And I want to contribute some codes, is there any guidance on that?
>>>>>
>>>>> --
>>>>> You received this message because you are subscribed to the Google
>>>>> Groups "Impala User" group.
>>>>> To unsubscribe from this group and stop receiving emails from it, send
>>>>> an email to impala-user...@cloudera.org.
>>>>>
>>>>
>>>> --
>>>> You received this message because you are subscribed to the Google
>>>> Groups "Impala User" group.
>>>> To unsubscribe from this group and stop receiving emails from it, send
>>>> an email to impala-user...@cloudera.org.
>>>>
>>>
>>> --
>> You received this message because you are subscribed to the Google Groups
>> "Impala User" group.
>> To unsubscribe from this group and stop receiving emails from it, send an
>> email to impala-user+unsubscribe@cloudera.org.
>>
>
> --
> You received this message because you are subscribed to the Google Groups
> "Impala User" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to impala-user+unsubscribe@cloudera.org.
>

Mime
View raw message