impala-reviews mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vuk Ercegovac (Code Review)" <ger...@cloudera.org>
Subject [Impala-ASF-CR] IMPALA-5538: Use explicit catalog versions for deleted objects
Date Tue, 12 Sep 2017 00:24:14 GMT
Vuk Ercegovac has posted comments on this change.

Change subject: IMPALA-5538: Use explicit catalog versions for deleted objects
......................................................................


Patch Set 2:

(4 comments)

http://gerrit.cloudera.org:8080/#/c/7731/2/be/src/catalog/catalog-server.cc
File be/src/catalog/catalog-server.cc:

PS2, Line 233:  0, if they have then skip this step and use that data
nit: perhaps easier to read? "...version 0. If so, then skip ..."


PS2, Line 336: if (topic_deletions) {
             :       VLOG(1) << "Publishing deletion: " << entry_key <<
"@"
             :           << catalog_object.catalog_version;
             :     } else {
             :       VLOG(1) << "Publishing update: " << entry_key << "@"
             :           << catalog_object.catalog_version;
             :     }
perhaps remove some redundancy this way:
VLOG(1) << "Publishing " 
    << (topic_deletions ? "deletion" : "update") 
    << ": " << entry_key << "@" 
    << catalog_object.catalog_version;


http://gerrit.cloudera.org:8080/#/c/7731/2/be/src/service/impala-server.cc
File be/src/service/impala-server.cc:

PS2, Line 1366: if (item.deleted) {
              :         VLOG(3) << "Deleted item: " << item.key << " version:
"
              :             << catalog_object.catalog_version;
              :       } else {
              :         VLOG(3) << "Added item: " << item.key << " version:
"
              :             << catalog_object.catalog_version;
              :       }
same suggestion as in catalog_server to reduce redundancy.


http://gerrit.cloudera.org:8080/#/c/7731/2/fe/src/main/java/org/apache/impala/catalog/CatalogServiceCatalog.java
File fe/src/main/java/org/apache/impala/catalog/CatalogServiceCatalog.java:

PS2, Line 152: .
the word "delta" implies that we're dealing with inserts, deletes, and possibly updates. any
reason why this member is named more generally? why not call it deleteLog_?


-- 
To view, visit http://gerrit.cloudera.org:8080/7731
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: I93cb7a033dc8f0d3e0339394b36affe14523274c
Gerrit-PatchSet: 2
Gerrit-Project: Impala-ASF
Gerrit-Branch: master
Gerrit-Owner: Dimitris Tsirogiannis <dtsirogiannis@cloudera.com>
Gerrit-Reviewer: Alex Behm <alex.behm@cloudera.com>
Gerrit-Reviewer: Bharath Vissapragada <bharathv@cloudera.com>
Gerrit-Reviewer: Dimitris Tsirogiannis <dtsirogiannis@cloudera.com>
Gerrit-Reviewer: Vuk Ercegovac <vercegovac@cloudera.com>
Gerrit-HasComments: Yes

Mime
View raw message