impala-reviews mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael Ho (Code Review)" <>
Subject [Impala-ASF-CR] IMPALA-5744: Add dummy 'use krpc' flag and create DataStream interface
Date Sun, 06 Aug 2017 02:44:54 GMT
Michael Ho has posted comments on this change.

Change subject: IMPALA-5744: Add dummy 'use_krpc' flag and create DataStream interface

Patch Set 8: Code-Review+2


Please also wait for comments from Henry.
Commit Message:

PS8, Line 7: dummy 'use_krpc' flag
The flag is not really dummy, right ? We are just using dummy implementation for KRPC for
now. Should we just say Add "use_krpc" flag.. Same below.

Line 20: DataStream*Base.
Using pure virtual base class may result in code duplication but the current approach is to
optimize for the eventual removal of the thrift implementations.

PS8, Line 27: Since having both the Thrift and KRPC implementations of the
            : DataStream* classes are only expected to be temporary for now, this
            : was written and optimized with the end goal of having only the KRPC
            : versions of the DataStreamMgr/Recvr, at which point we will get rid
            : of the DataStream*Base classes, the Thrift versions of the classes
            : and rename KrpcDataStream* to DataStream*. We will also rename all
            : the references that the clients have to DataStream*Base to DataStream*.
May remove or shorten this entire paragraph if you take the one line suggestion above.
File be/src/runtime/data-stream-mgr-base.h:

PS8, Line 35: enforces a basic interface
defines the basic interface

PS8, Line 36: , one each for Thrift and KRPC.
for thrift and KRPC respectively.
File be/src/runtime/data-stream-recvr-base.h:

PS8, Line 32: enforces a basic interface
defines the basic interface

PS8, Line 33: , one each for Thrift and KRPC
for thrift and KRPC respectively.
File be/src/runtime/exec-env.h:

PS8, Line 92: Clients of the implementations of DataStreamMgrBase should not use these functions
Clients of DataStreamMgrBase should use stream_mgr() unless ...

To view, visit
To unsubscribe, visit

Gerrit-MessageType: comment
Gerrit-Change-Id: I5d52245154e910529a68f53049520238eca16241
Gerrit-PatchSet: 8
Gerrit-Project: Impala-ASF
Gerrit-Branch: master
Gerrit-Owner: Sailesh Mukil <>
Gerrit-Reviewer: Henry Robinson <>
Gerrit-Reviewer: Michael Ho <>
Gerrit-Reviewer: Sailesh Mukil <>
Gerrit-HasComments: Yes

View raw message