impala-reviews mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "anujphadke (Code Review)" <ger...@cloudera.org>
Subject [Impala-ASF-CR] IMPALA-4863/IMPALA-5311: Correctly account the file type and compression codec
Date Mon, 31 Jul 2017 22:37:14 GMT
anujphadke has posted comments on this change.

Change subject: IMPALA-4863/IMPALA-5311: Correctly account the file type and compression codec
......................................................................


Patch Set 4:

(5 comments)

http://gerrit.cloudera.org:8080/#/c/7245/3/be/src/exec/hdfs-scan-node-base.cc
File be/src/exec/hdfs-scan-node-base.cc:

Line 27: #include <sstream>
> Shouldn't this be in the header instead of the .cc?
Done


Line 776:   vector<THdfsCompression::type> types;
> Parameter names don't match header
Done


Line 883:             // If a scan range stored as parquet is skipped, its compression type
> One line comment explaining why Parquet is a special case.
Done


PS3, Line 886:   } else {
             :             ss << file_format << "/
> AVRO/SNAPPY(Skipped) I think reads better
Done. Changed it everywhere.


http://gerrit.cloudera.org:8080/#/c/7245/3/be/src/exec/hdfs-scan-node-base.h
File be/src/exec/hdfs-scan-node-base.h:

Line 257:   /// in the file. The metrics are incremented for each compression_type.
> Parameter names are inconsistent - skipped vs filtered. We should also docu
Done


-- 
To view, visit http://gerrit.cloudera.org:8080/7245
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: I797916505f62e568f4159e07099481b8ff571da2
Gerrit-PatchSet: 4
Gerrit-Project: Impala-ASF
Gerrit-Branch: master
Gerrit-Owner: anujphadke <aphadke@cloudera.com>
Gerrit-Reviewer: Tim Armstrong <tarmstrong@cloudera.com>
Gerrit-Reviewer: anujphadke <aphadke@cloudera.com>
Gerrit-HasComments: Yes

Mime
View raw message