impala-reviews mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dan Hecht (Code Review)" <>
Subject [Impala-ASF-CR] IMPALA-4862: make resource profile consistent with backend behaviour
Date Thu, 06 Jul 2017 22:19:44 GMT
Dan Hecht has posted comments on this change.

Change subject: IMPALA-4862: make resource profile consistent with backend behaviour

Patch Set 13:


The backend changes look good.  I'll make another pass through the frontend, but let's first
finalize the thrift change to make sure we're on the same page.
File be/src/exec/exec-node.h:

PS13, Line 88: t  
nit: double space
File common/thrift/Frontend.thrift:

PS13, Line 395: does not overlap.
shouldn't that be: do overlap?

PS13, Line 398: per-host minimum buffer reservations
that makes it sound like it's directly related to the thing above. maybe say instead:

Sum of the per-plan-node minimum buffer reservations over all operators in the query plan.

The fact that it's per-host is kind of implied then (since we're talking about nodes in the
plan), and seems secondary to the fact that it's over the plan anyway (given what it's for).

PS13, Line 400: per_host_min_reservation_su
that name makes it sound like it's a sum of the previous field.  Would

sum_per_node_min_reservation or total_per_node_min_reservation

make sense?
File fe/src/main/java/org/apache/impala/planner/

Line 662:       // then closed before Open() of this node returns.
but that's not true if InSubplan, right?
File fe/src/main/java/org/apache/impala/planner/

PS13, Line 354: // Sum of per-host minimum reservations over all plan nodes and sinks. Used
to manage
              :     // a pool of initial reservations: once this amount of initial reservation
has been
              :     // claimed, no more initial reservations will be claimed.
              :     long perHostMinimumReservationSum = 0;
let's rename this to be consistent with whatever we converge on for the thrift naming and
thrift comment

To view, visit
To unsubscribe, visit

Gerrit-MessageType: comment
Gerrit-Change-Id: I492cf5052bb27e4e335395e2a8f8a3b07248ec9d
Gerrit-PatchSet: 13
Gerrit-Project: Impala-ASF
Gerrit-Branch: master
Gerrit-Owner: Tim Armstrong <>
Gerrit-Reviewer: Alex Behm <>
Gerrit-Reviewer: Dan Hecht <>
Gerrit-Reviewer: Tim Armstrong <>
Gerrit-HasComments: Yes

View raw message