impala-reviews mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lars Volker (Code Review)" <ger...@cloudera.org>
Subject [Impala-ASF-CR] IMPALA-5428: update external hadoop ecosystem versions
Date Mon, 05 Jun 2017 05:25:04 GMT
Lars Volker has posted comments on this change.

Change subject: IMPALA-5428: update external hadoop ecosystem versions
......................................................................


Patch Set 1:

> > Is this change affected by the Hive schema version problem?
 > 
 > I tried this locally and after cherry picking this change, Hive
 > wouldn't start anymore. I suspect it will take https://gerrit.cloudera.org/#/c/7072/
 > and a data reload to get it to work again.

I was able to use the Hive schematool to upgrade my schema like so:

/opt/Impala-Toolchain/cdh_components/hive-1.1.0-cdh5.13.0-SNAPSHOT/bin/schematool -upgradeSchema
-dbType postgres

It printed an error but still seems to have worked:
✔ ~/i1(master) ✗$ /opt/Impala-Toolchain/cdh_components/hive-1.1.0-cdh5.13.0-SNAPSHOT/bin/schematool
-upgradeSchema -dbType postgres
SLF4J: Class path contains multiple SLF4J bindings.
SLF4J: Found binding in [jar:file:/opt/Impala-Toolchain/cdh_components/hbase-1.2.0-cdh5.13.0-SNAPSHOT/lib/slf4j-log4j12-1.7.5.jar!/org/slf4j/impl/StaticLoggerBinder.class]
SLF4J: Found binding in [jar:file:/opt/Impala-Toolchain/cdh_components/hadoop-2.6.0-cdh5.13.0-SNAPSHOT/share/hadoop/common/lib/slf4j-log4j12-1.7.5.jar!/org/slf4j/impl/StaticLoggerBinder.class]
SLF4J: See http://www.slf4j.org/codes.html#multiple_bindings for an explanation.
SLF4J: Actual binding is of type [org.slf4j.impl.Log4jLoggerFactory]
17/06/04 22:20:00 WARN conf.HiveConf: HiveConf of name hive.access.conf.url does not exist
Comparing cdh5.12.0 with cdh5.13.0
Version 12 is lower than 13
Comparing cdh5.13.0 with cdh5.13.0
Metastore connection URL:        jdbc:postgresql://localhost:5432/hive_impala
Metastore Connection Driver :    org.postgresql.Driver
Metastore connection User:       hiveuser
Starting upgrade metastore schema from version 1.1.0 to 1.1.0-cdh5.13.0
Upgrade script upgrade-1.1.0-to-1.1.0-cdh5.12.0.postgres.sql
Error: ERROR: column "SCHEMA_VERSION_V2" of relation "VERSION" does not exist (state=42703,code=0)
Warning in pre-upgrade script pre-0-upgrade-1.1.0-to-1.1.0-cdh5.12.0.postgres.sql: Schema
script failed, errorcode 2
Completed upgrade-1.1.0-to-1.1.0-cdh5.12.0.postgres.sql
Upgrade script upgrade-1.1.0-cdh5.12.0-to-1.1.0-cdh5.13.0.postgres.sql
Completed upgrade-1.1.0-cdh5.12.0-to-1.1.0-cdh5.13.0.postgres.sql
17/06/04 22:20:00 INFO metastore.CDHMetaStoreSchemaInfo: Upstream versions are compatible,
comparing downstream
Comparing cdh5.13.0 with cdh5.13.0
schemaTool completed

-- 
To view, visit http://gerrit.cloudera.org:8080/7076
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: Ib96c7532d381e1527dfc653709c6ecba3bbd16c4
Gerrit-PatchSet: 1
Gerrit-Project: Impala-ASF
Gerrit-Branch: master
Gerrit-Owner: Thomas Tauber-Marshall <tmarshall@cloudera.com>
Gerrit-Reviewer: Lars Volker <lv@cloudera.com>
Gerrit-Reviewer: Michael Brown <mikeb@cloudera.com>
Gerrit-HasComments: No

Mime
View raw message