impala-reviews mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alex Behm (Code Review)" <ger...@cloudera.org>
Subject [Impala-ASF-CR] IMPALA-3586: Implement union passthrough
Date Fri, 17 Mar 2017 05:51:12 GMT
Alex Behm has posted comments on this change.

Change subject: IMPALA-3586: Implement union passthrough
......................................................................


Patch Set 17:

(8 comments)

I'm pretty happy with the change. Only minor comment/naming issue left to fix.

http://gerrit.cloudera.org:8080/#/c/5816/17//COMMIT_MSG
Commit Message:

Line 19: A new query option DISABLE_UNION_PASSTHROUGH was added in this patch
No more query option.


http://gerrit.cloudera.org:8080/#/c/5816/17/be/src/exec/union-node.h
File be/src/exec/union-node.h:

Line 32: class RuntimeState;
remove


Line 70:   /// evaluating its exprs.
Just or clarity it might help to spell out what its value is when all children are materialized
and when no children are materialized


Line 71:   int first_materialized_child_idx_;
make const and set in c'tor


Line 100:   /// call on the child. Sets 'passthrough_todo_' to false when all passthrough
children
update comments to not mention 'todo'


http://gerrit.cloudera.org:8080/#/c/5816/17/fe/src/main/java/org/apache/impala/planner/UnionNode.java
File fe/src/main/java/org/apache/impala/planner/UnionNode.java:

Line 77:   // Index of the first non-passthrough child; i.e. a child that needs materializing
and
Shrink to: // Index of the first non-passthrough child.


Comment says it all :). The class comment already explains what passthrough is


Line 183:    * Re-order the union's operands such that the passthrough operands come before
the
I'd say the main purpose of this function is to compute passthrough. The re-ordering is secondary.
So how about calling this computePassthrough().

Would also be good to mention that we reorder based on passthrough mostly for simplifying
the BE implementation.


Line 190:       isChildPassthrough.add(computePassthrough(
You could rename this computePassthrough() to isChildPassthrough()


-- 
To view, visit http://gerrit.cloudera.org:8080/5816
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: Ia8f6d5062724ba5b78174c3227a7a796d10d8416
Gerrit-PatchSet: 17
Gerrit-Project: Impala-ASF
Gerrit-Branch: master
Gerrit-Owner: Taras Bobrovytsky <tbobrovytsky@cloudera.com>
Gerrit-Reviewer: Alex Behm <alex.behm@cloudera.com>
Gerrit-Reviewer: Dan Hecht <dhecht@cloudera.com>
Gerrit-Reviewer: Marcel Kornacker <marcel@cloudera.com>
Gerrit-Reviewer: Taras Bobrovytsky <tbobrovytsky@cloudera.com>
Gerrit-Reviewer: Tim Armstrong <tarmstrong@cloudera.com>
Gerrit-HasComments: Yes

Mime
View raw message